summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2018-04-28 13:21:50 +0300
committerErnestas Kulik <ernestask@gnome.org>2018-05-22 16:52:48 +0300
commit673c81cf9f1d68b71041220e6e44624dee44dbfc (patch)
tree85637603bbf6e2333ae7a0bbcb52068ca655ad8d /meson.build
parent0aca206f8a47c3b35d3d0bc2964e5f672d7a3794 (diff)
downloadnautilus-673c81cf9f1d68b71041220e6e44624dee44dbfc.tar.gz
general: Copy gnome-desktop thumbnailing code
This is one of prerequisite steps to take before fully switching to GTK+ 4, as gnome-desktop has code, depending on GTK+ 3. Since the thumbnailing machinery is self-contained, it can easily be just copied over.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 18 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f909183c4..b68cf04ac 100644
--- a/meson.build
+++ b/meson.build
@@ -78,8 +78,9 @@ gio_unix = dependency('gio-unix-2.0', version: glib_ver)
glib = dependency('glib-2.0', version: glib_ver)
gmodule = dependency('gmodule-no-export-2.0', version: glib_ver)
gnome_autoar = dependency('gnome-autoar-0', version: '>= 0.2.1')
-gnome_desktop = dependency('gnome-desktop-3.0', version: '>= 3.0.0')
+gsettings_desktop_schemas = dependency('gsettings-desktop-schemas')
gtk = dependency('gtk+-3.0', version: '>= 3.22.27')
+seccomp = dependency('libseccomp')
selinux = []
if get_option('selinux')
selinux = dependency('libselinux', version: '>= 2.0')
@@ -113,9 +114,25 @@ conf.set_quoted('LOCALEDIR', join_paths(prefix, get_option('localedir')))
conf.set_quoted('NAUTILUS_DATADIR', join_paths(datadir, 'nautilus'))
conf.set_quoted('NAUTILUS_EXTENSIONDIR', join_paths(prefix, extensiondir))
conf.set_quoted('APPLICATION_ID', application_id)
+conf.set_quoted('INSTALL_PREFIX', prefix)
conf.set_quoted('PROFILE', profile)
conf.set_quoted('NAME_SUFFIX', name_suffix)
+
+# _ _ _
+# __ _ _ __ ___ _ __ ___ ___ __| | ___ ___| | _| |_ ___ _ __
+# / _` | '_ \ / _ \| '_ ` _ \ / _ \_____ / _` |/ _ \/ __| |/ / __/ _ \| '_ \
+#| (_| | | | | (_) | | | | | | __/_____| (_| | __/\__ \ <| || (_) | |_) |
+# \__, |_| |_|\___/|_| |_| |_|\___| \__,_|\___||___/_|\_\\__\___/| .__/
+# |___/ |_|
+#
+# gnome-desktop macros for thumbnailer sandboxing.
+####################################
+conf.set10('_GNU_SOURCE', true) # `man user_namespaces` /CLONE_NEWUSER
+conf.set10('ENABLE_SECCOMP', true) #
+conf.set10('HAVE_BWRAP', true) #
+####################################
+
if get_option('packagekit')
conf.set10('ENABLE_PACKAGEKIT', true)
endif