summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2018-01-31 10:24:07 +0200
committerErnestas Kulik <ernestask@gnome.org>2018-02-09 06:32:38 +0200
commit14ee0f1cdc9c02e6fc49024786eb6ef47be5a176 (patch)
treebe2ae9c936a30b288ba614be7abd1203dc0d4109 /meson.build
parent7e2605c681d065e6b0a3d779c30b892932597991 (diff)
downloadnautilus-14ee0f1cdc9c02e6fc49024786eb6ef47be5a176.tar.gz
general: reimplement image properties as an extension
The image property page is already implemented using the extension API, but it’s not an extension and relies on a library that is not essential to Nautilus. This commit builds the image properties as an extension and introduces some minor refactoring to the code.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 33b37dc9c..37fde5ed9 100644
--- a/meson.build
+++ b/meson.build
@@ -84,7 +84,10 @@ endif
configure_file(output: 'config.h', configuration: conf)
#
-nautilus_include_dirs = include_directories('.')
+nautilus_include_dirs = include_directories(
+ '.',
+ 'libnautilus-extension'
+)
subdir('eel')
subdir('libnautilus-extension')
@@ -96,6 +99,7 @@ subdir('po')
if get_option('docs')
subdir('docs')
endif
+subdir('extensions')
if get_option('nst_extension')
subdir('nautilus-sendto-extension')
endif