summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Soriano <csoriano@redhat.com>2018-07-14 10:00:39 +0200
committerCarlos Soriano <csoriano@redhat.com>2018-07-14 11:33:57 +0200
commitd31b8b59de62ae06b49c666893b02614a6ecf059 (patch)
treed98cf4ebf7339c6ab68bfc0063966ee04913634e /meson.build
parentfd309ecfbc277409f1690f7746bc0472b99d1866 (diff)
downloadnautilus-d31b8b59de62ae06b49c666893b02614a6ecf059.tar.gz
general: Assume development profile if app id is not Nautilus
Instead of checking explicitly for some options, we allow any value as profile and assume is a development snapshot. This will help with having Flatpak bundles/refs of different branches with different purposes.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 7bbf38b8f..4dc8ffebb 100644
--- a/meson.build
+++ b/meson.build
@@ -98,10 +98,9 @@ conf = configuration_data()
if get_option('profile') == 'development'
profile = 'Devel'
name_suffix = ' (Development Snapshot)'
-elif get_option('profile') == 'stable-flatpak'
- profile = 'StableFlatpak'
- version_array = meson.project_version().split('.')
- name_suffix = ' (@0@.@1@ Flatpak)'.format(version_array[0], version_array[1])
+elif get_option('profile') != ''
+ profile = get_option('profile')
+ name_suffix = get_option('profile')
else
profile = ''
name_suffix = ''