summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlexandru Fazakas <alex.fazakas97@yahoo.com>2018-03-20 21:02:49 +0200
committerAlexandru Fazakas <alex.fazakas97@yahoo.com>2018-03-21 23:57:56 +0200
commit315d14585bf40188780d9433887a7b3681d28eb4 (patch)
tree02ba812b1b7f46508052d8179a81125102bc89dd /meson.build
parente3c01df382ac41ed4657463b9d4d60a7e7dff4a3 (diff)
downloadnautilus-315d14585bf40188780d9433887a7b3681d28eb4.tar.gz
list-view: Make list view selection consistent
Selecting rows using CTRL/SHIFT with left click is different to right click as GtkTreeView's default code does not support SHIFT+CTRL selection. We want consistency between the two behaviours. We fixed this by replicating the left click behaviour in the right click case. The GTK dependency is also bumped in order to use GtkTreePath autocleanup.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 99126aadb..cd3006932 100644
--- a/meson.build
+++ b/meson.build
@@ -79,7 +79,7 @@ glib = dependency('glib-2.0', version: glib_ver)
gmodule = dependency('gmodule-no-export-2.0', version: glib_ver)
gnome_autoar = dependency('gnome-autoar-0', version: '>= 0.2.1')
gnome_desktop = dependency('gnome-desktop-3.0', version: '>= 3.0.0')
-gtk = dependency('gtk+-3.0', version: '>= 3.22.26')
+gtk = dependency('gtk+-3.0', version: '>= 3.22.27')
selinux = []
if get_option('selinux')
selinux = dependency('libselinux', version: '>= 2.0')