summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2017-07-14 11:24:30 +0200
committerBastien Nocera <hadess@hadess.net>2017-07-18 03:25:03 +0200
commit4ac20d7b6a032a654128e7e51bb141bd04d46c24 (patch)
tree743394a64b1fa1459b3fde7bff1180fcaa47b6d8 /meson.build
parent365ec7f7ac1cec51dc0248dd05b17cb78252a788 (diff)
downloadnautilus-4ac20d7b6a032a654128e7e51bb141bd04d46c24.tar.gz
build: Fix tracker detection
Make sure that tracker-sparql is optional and auto-detected by default and that tracker-sparql-1.0 is still supported. https://bugzilla.gnome.org/show_bug.cgi?id=784940
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 85c3cb9da..4160c8fe0 100644
--- a/meson.build
+++ b/meson.build
@@ -81,9 +81,13 @@ if get_option ('enable-selinux')
conf.set10 ('HAVE_SELINUX', true)
endif
-if get_option ('enable-tracker')
- tracker_sparql = dependency ('tracker-sparql-2.0')
- conf.set10 ('ENABLE_TRACKER', true)
+tracker_option = get_option ('enable-tracker')
+if tracker_option != 'no'
+ tracker_sparql = dependency ('tracker-sparql-2.0', required: (tracker_option == 'yes'))
+ if not tracker_sparql.found()
+ tracker_sparql = dependency ('tracker-sparql-1.0', required: (tracker_option == 'yes'))
+ endif
+ conf.set10 ('ENABLE_TRACKER', tracker_sparql.found())
endif
if get_option ('enable-xmp')