summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2018-01-31 10:27:52 +0200
committerErnestas Kulik <ernestask@gnome.org>2018-02-09 06:32:38 +0200
commit6934578ebf6e1959ad0634b73196242a30514095 (patch)
tree51b506c93cebaf0ab4ae4aef7ad1797d925aacce /meson.build
parent14ee0f1cdc9c02e6fc49024786eb6ef47be5a176 (diff)
downloadnautilus-6934578ebf6e1959ad0634b73196242a30514095.tar.gz
sendto-extension: move under extensions/
Now that the image property page is an extension, both extensions can be held under the same subdirectory. This commit also makes the image property extension optional.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 37fde5ed9..ab225e360 100644
--- a/meson.build
+++ b/meson.build
@@ -44,7 +44,9 @@ libgd_dep = libgd.get_variable('libgd_dep')
libm = cc.find_library('libm')
gail = dependency('gail-3.0')
-gexiv = dependency('gexiv2', version: '>= 0.10.0')
+if get_option('extensions')
+ gexiv = dependency('gexiv2', version: '>= 0.10.0')
+endif
gio = dependency('gio-2.0', version: glib_ver)
gio_unix = dependency('gio-unix-2.0', version: glib_ver)
glib = dependency('glib-2.0', version: glib_ver)
@@ -99,9 +101,8 @@ subdir('po')
if get_option('docs')
subdir('docs')
endif
-subdir('extensions')
-if get_option('nst_extension')
- subdir('nautilus-sendto-extension')
+if get_option('extensions')
+ subdir('extensions')
endif
# Compile GSettings schemas when installing from source.