summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAntónio Fernandes <antoniof@gnome.org>2022-06-06 11:31:12 +0100
committerAntónio Fernandes <antoniof@gnome.org>2022-06-21 19:55:00 +0100
commitb28e2d545dca3177cf91b3c2bc1855abace719f0 (patch)
tree6f9a60a896e3bf4209628ab16a47d718ec373025 /meson.build
parent815b9e0026dbc728e00aba8f399cf4f557f833c8 (diff)
downloadnautilus-b28e2d545dca3177cf91b3c2bc1855abace719f0.tar.gz
view-icon-controller: Abstract sharable code
The new list view is going to be GtkColumnView-based, so it's going to share some code with the GtkGridView-based view. In order to avoid code duplication and still keep the NautilusFilesView class agnostic of the widgets used by final classes, create an abstract NautilusListBase class. But this abstract class needs to interact with the item widgets, which are going to be different between views. To resolve this, an abstract NautilusViewCell class is created for the item widgets, which is also going to be used for the new list view column cells. Also, bump GLib version requirement now that we use GSignalGroup.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 154c7b763..7af5a3ef0 100644
--- a/meson.build
+++ b/meson.build
@@ -92,7 +92,7 @@ pkgconfig = import('pkgconfig')
################
# Dependencies #
################
-glib_ver = '>= 2.67.1'
+glib_ver = '>= 2.72.0'
libm = cc.find_library('m')