summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMaxim Mikityanskiy <maxtram95@gmail.com>2020-08-16 17:56:03 +0300
committerMaxim Mikityanskiy <maxtram95@gmail.com>2021-01-09 16:33:49 +0200
commitf29b4839187c0ab18dd2cf1fd99c7cb734cab8ff (patch)
treec2d38dc9f19d0e152e1088a4070b002897391b29 /meson.build
parent96b466877071a1e458e1597338fc5cb3e712af52 (diff)
downloadnautilus-f29b4839187c0ab18dd2cf1fd99c7cb734cab8ff.tar.gz
file-operations: Preserve mtime of non-empty directories on move
Nautilus follows this algorithm when copying or moving directories: 1. Create the destination directory. 2. Copy/move the old directory contents recursively. 3. g_file_copy_attributes from the old directory to the new. 4. Delete the old directory. The issue is that when moving a non-empty directory, step 2 leads to modification of the old directory's mtime, so g_file_copy_attributes copies the attributes that were already lost at that point. This commit fixes it by splitting g_file_copy_attributes into two steps. It depends on glib!1449. Closes: gvfs#471 Signed-off-by: Maxim Mikityanskiy <maxtram95@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a5413d54c..3d9aaa340 100644
--- a/meson.build
+++ b/meson.build
@@ -93,7 +93,7 @@ pkgconfig = import('pkgconfig')
################
# Dependencies #
################
-glib_ver = '>= 2.62.0'
+glib_ver = '>= 2.67.1'
libgd = subproject(
'libgd',