summaryrefslogtreecommitdiff
path: root/nautilus-installer/src/Makefile.am
diff options
context:
space:
mode:
authorEskil Heyn Olsen <eskil@src.gnome.org>2000-05-31 03:56:26 +0000
committerEskil Heyn Olsen <eskil@src.gnome.org>2000-05-31 03:56:26 +0000
commit6d52e1b57cc0d9f19e52ba12bae7f398b6215347 (patch)
tree0fbbd3742a3a3a26064663413c3abb9e0f358fc7 /nautilus-installer/src/Makefile.am
parent4412765d7fd0d117d1617b033f2eca7825f6bea5 (diff)
downloadnautilus-6d52e1b57cc0d9f19e52ba12bae7f398b6215347.tar.gz
Removed the Makefile.in's and added the .am instead.
* nautilus-installer/Makefile.in: * nautilus-installer/src/Makefile.am: * nautilus-installer/src/Makefile.in: Removed the Makefile.in's and added the .am instead.
Diffstat (limited to 'nautilus-installer/src/Makefile.am')
-rw-r--r--nautilus-installer/src/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/nautilus-installer/src/Makefile.am b/nautilus-installer/src/Makefile.am
new file mode 100644
index 000000000..e70062c77
--- /dev/null
+++ b/nautilus-installer/src/Makefile.am
@@ -0,0 +1,59 @@
+## Process this file with automake to produce Makefile.in
+
+NULL =
+
+INCLUDES = \
+ -I$(top_srcdir)/components/services/install/lib \
+ $(GNOMEUI_CFLAGS) \
+ $(XML_CFLAGS) \
+ $(GNET_CFLAGS) \
+ $(GHTTP_CFLAGS) \
+ $(GNOME_INCLUDEDIR) \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DG_LOG_DOMAIN=\"Nautilus-Installer\" \
+ $(NULL)
+
+CFLAGS = -O $(WERROR)
+
+bin_PROGRAMS = nautilus-installer
+
+nautilus_installer_SOURCES = \
+ main.c \
+ support.c support.h \
+ interface.c interface.h \
+ callbacks.c callbacks.h \
+ installer.c installer h
+
+nautilus_installer_LDFLAGS = -static
+
+nautilus_installer_LDADD = \
+ $(top_builddir)/components/services/trilobite/libtrilobite/helixcode-utils.o \
+ $(top_builddir)/components/services/install/lib/libinstall.a \
+ -L/gnome/lib \
+ -lgnomeui \
+ -lgnome \
+ -lart_lgpl \
+ -lgdk_imlib \
+ -lgtk \
+ -lgdk \
+ -lgmodule \
+ -lglib \
+ -L/usr/X11R6/lib -ldl -lXext -lX11 -lm -lSM -lICE \
+ /usr/lib/libesd.a \
+ /usr/lib/libaudiofile.a \
+ -lghttp \
+ -L/usr/lib -lrpm -lz -ldb1 \
+ -lpopt \
+ -lxml
+
+#
+# /gnome-source/nautilus/components/services/trilobite/libtrilobite/helixcode-utils.o \
+# /gnome-source/nautilus/components/services/install/lib/libinstall.a \
+# $(GNOME_LIBDIR) \
+# $(GNOMEUI_LIBS) \
+# $(GHTTP_LIBS) \
+# $(INTLLIBS) \
+# $(XML_LIBS) \
+# $(RPM_LIBS) \
+# $(NULL)
+