summaryrefslogtreecommitdiff
path: root/src-ng/meson.build
diff options
context:
space:
mode:
authorErnestas Kulik <ernestask@gnome.org>2017-07-18 12:47:24 +0300
committerErnestas Kulik <ernestask@gnome.org>2017-08-17 18:54:05 +0300
commitbb896a04237260b5661616655503d0bab97da748 (patch)
treeb6ae65e1ea01312cc853ee37a84a667dc7c7a9cf /src-ng/meson.build
parent4b95294d8592a576160a162b06d90060b4d66b78 (diff)
downloadnautilus-bb896a04237260b5661616655503d0bab97da748.tar.gz
Implement renaming with change notifications
This is fairly bare-bones in that there is still a couple of problems to solve before this is actually useful. 1. Rename task: error signaling? Possible solutions are: 1. Block thread on each error, fire a signal and wait for return value. 2. Collect all errors, fire a signal, wait for return value. 3. Pass errors to the “finished” signal. 2. Although unlikely, but, in theory, the changes queue could never get flushed, as the timer is reset with each push (a hardcoded limit can be used, which would force a flush - sound familiar? :p). 3. Rename task (again): the “finished” signal will usually arrive before changed files and their parents are notified, which presents a glorious race to work around in the test executable (quitting the main loop, namely). There is probably something else that I forgot to mention.
Diffstat (limited to 'src-ng/meson.build')
-rw-r--r--src-ng/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src-ng/meson.build b/src-ng/meson.build
index aa6288410..81b7d021d 100644
--- a/src-ng/meson.build
+++ b/src-ng/meson.build
@@ -1,5 +1,6 @@
nautilus_ng_sources = ['nautilus-task.c',
'nautilus-task.h',
+ 'nautilus-task-private.h',
'nautilus-task-manager.c',
'nautilus-task-manager.h',
'nautilus-file.c',
@@ -12,6 +13,12 @@ nautilus_ng_sources = ['nautilus-task.c',
'tasks/nautilus-enumerate-children-task.h',
'nautilus-cache.c',
'nautilus-cache.h',
+ 'tasks/nautilus-rename-task.c',
+ 'tasks/nautilus-rename-task.h',
+ 'nautilus-file-changes.c',
+ 'nautilus-file-changes.h',
+ 'nautilus-signal-utilities.c',
+ 'nautilus-signal-utilities.h',
'main.c']
nautilus_ng_dependencies = [gio, glib]