summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRazvan Chitu <razvan.ch95@gmail.com>2016-08-21 19:06:51 +0300
committerRazvan Chitu <razvan.ch95@gmail.com>2016-08-23 00:35:33 +0300
commitfd01842f996b7d07baf2aafb0f68308fc5ed2055 (patch)
tree434278662cd52a707ce4a0f4a3593cc930ec7369 /src/Makefile.am
parentc389f97792143ec354369cc38729bfcb0fa106fb (diff)
downloadnautilus-fd01842f996b7d07baf2aafb0f68308fc5ed2055.tar.gz
file-conflict-dialog: separate file logic from UI management
In Nautilus, file conflicts are handled by a specific dialog. Previously, the dialog class managed both the UI and the related nautilus files. This lead to it being inflexible due to operation specific logic being mixed with the rest of the functionality. In order to change this, move file logic to a separate module and add methods for controlling the UI elements in the dialog. Create an operation-manager module to handle dialog controlling. Move anything related to Nautilus files from the dialog class to the new module. https://bugzilla.gnome.org/show_bug.cgi?id=770160
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 652cab7ce..6532c0101 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -278,6 +278,8 @@ nautilus_no_main_sources = \
nautilus-rename-file-popover-controller.h \
nautilus-new-folder-dialog-controller.c \
nautilus-new-folder-dialog-controller.h \
+ nautilus-operations-ui-manager.c \
+ nautilus-operations-ui-manager.h \
nautilus-file-operations.c \
nautilus-file-operations.h \
nautilus-file-private.h \