summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2015-08-18 15:23:02 -0300
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2015-08-20 17:38:35 -0300
commit404f1492dbe03b407abd4ca0c2b743f7810f4b3e (patch)
treebabcbe37fa37648d8731acd20a19e0967ebe8cc9 /src/Makefile.am
parentabef8cac2f1df4b808fcb66b35877b75b54774e4 (diff)
downloadnautilus-404f1492dbe03b407abd4ca0c2b743f7810f4b3e.tar.gz
places-view: implement a view for Other Locations
GtkFileChooser received a Other Locations view that lists persistent devices, as well as networks and the root location for the computer's hard drive. Since Nautilus is a file management tool too, it should keep consistency between Gtk+ file chooser, something that doesn't happen since it doesn't display Other Locations. To fix that, add NautilusPlacesView, a NautilusView implementation that displays the GtkPlacesView widget. In order to implement that, update window-slot to correctly display the places-view whenever Other Locations is clicked. https://bugzilla.gnome.org/show_bug.cgi?id=753871
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2b01996db..56972248b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -139,6 +139,10 @@ nautilus_built_sources = \
$(NULL)
nautilus_SOURCES = \
+ gtk/gtkplacesview.c \
+ gtk/gtkplacesviewprivate.h \
+ gtk/gtkplacesviewrow.c \
+ gtk/gtkplacesviewrowprivate.h \
nautilus-application.c \
nautilus-application.h \
nautilus-application-actions.c \
@@ -189,6 +193,8 @@ nautilus_SOURCES = \
nautilus-notebook.h \
nautilus-pathbar.c \
nautilus-pathbar.h \
+ nautilus-places-view.c \
+ nautilus-places-view.h \
nautilus-previewer.c \
nautilus-previewer.h \
nautilus-progress-info-widget.c \