summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorEskil Heyn Olsen <eskil@src.gnome.org>2000-06-27 01:58:34 +0000
committerEskil Heyn Olsen <eskil@src.gnome.org>2000-06-27 01:58:34 +0000
commit8491d1a326f4ccaccdf6bc33be6a758f7ab8a8cf (patch)
tree33b1dafd060e6a458c14c2d2e45f1c96ccb66577 /test/Makefile.am
parent06a43fbbb54d4a404f6b55857f2206ec498fcdd3 (diff)
downloadnautilus-8491d1a326f4ccaccdf6bc33be6a758f7ab8a8cf.tar.gz
Rearranged so libeazelinstall is built before rpmview
* components/Makefile.am: Rearranged so libeazelinstall is built before rpmview * components/help/Makefile.am: Added a missing .h file so make dist works * components/rpmview/Makefile.am: * components/rpmview/nautilus-rpm-view-install.c: (nautilus_rpm_view_download_progress_signal), (nautilus_rpm_view_install_progress_signal), (nautilus_rpm_view_download_failed), (nautilus_rpm_view_install_failed_helper), (nautilus_rpm_view_install_failed), (nautilus_rpm_view_dependency_check), (nautilus_rpm_view_install_done), (nautilus_rpm_view_install_package_callback): * components/rpmview/nautilus-rpm-view-install.h: * components/rpmview/nautilus-rpm-view.c: (nautilus_rpm_view_initialize): Added a callback and some skeleton code to the install button. So it now does rpm installs. * components/services/install/lib/Makefile.am: * components/services/install/command-line/Makefile.am: Changed the libnames. * components/services/install/command-line/eazel-alt-install-corba.c: (done), (main): * components/services/install/lib/eazel-install-corba-callback.c: (eazel_install_callback_destroy), (eazel_install_callback_initialize), (eazel_install_callback_new), (eazel_install_callback_corba_objref), (eazel_install_callback_install_packages), (eazel_install_callback_query): * components/services/install/lib/eazel-install-corba-callback.h: * components/services/install/lib/eazel-install-corba-types.h: * components/services/install/lib/eazel-install-protocols.c: (get_search_url_for_package): * components/services/install/server/Makefile.am: * components/services/install/server/main.c: Changed the object destroction scheme, so eazel_install_callback now unrefs and destroys the bonobo object. * components/services/trilobite/sample/lib/Makefile.am: Fixed to pass make dist * nautilus-installer/src/Makefile: * nautilus-installer/src/Makefile.am: Patching so it works with the new installer libs (and still some stroking because of the static stuff) * nautilus.spec.in: * po/POTFILES.in: * test/Makefile.am: Slice and dice so make dist and rpm -ta works again.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 0367beace..baec10917 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -75,6 +75,10 @@ CLEANFILES += libleakcheck.so
libleakcheck.so: nautilus-leak-checker.c nautilus-leak-hash-table.c nautilus-leak-symbol-lookup.c
gcc nautilus-leak-checker.c nautilus-leak-hash-table.c nautilus-leak-symbol-lookup.c -Wall -o $@ -shared $(GLIB_CFLAGS) $(GLIB_LIBS) -lpthread -ldl -Wl,-Bstatic -lbfd -liberty -Wl,-Bdynamic
+# to include them in "make dist"
+EXTRA_DIST = nautilus-leak-checker.c nautilus-leak-hash-table.c nautilus-leak-symbol-lookup.c \
+ nautilus-leak-checker-stubs.h nautilus-leak-hash-table.h nautilus-leak-checker.h nautilus-leak-symbol-lookup.h
+
leakcheck_DATA = libleakcheck.so
leakcheckdir= $(DESTDIR)$(libdir)