summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRamiro Estrugo <ramiro@src.gnome.org>2000-07-10 13:14:58 +0000
committerRamiro Estrugo <ramiro@src.gnome.org>2000-07-10 13:14:58 +0000
commit747245d712e4f56c9c2dc6ffd30b9fa14e262b91 (patch)
treef466cf541fff224ead4f25d776ff45748f1ff323 /test/Makefile.am
parent33d57594f3a725f95ce98c0a8aa04c1eb3f3d17a (diff)
downloadnautilus-747245d712e4f56c9c2dc6ffd30b9fa14e262b91.tar.gz
Add arlo's services title icons.
* components/services/startup/nautilus-view/icons/Makefile.am, eazel-services-logo.png, eazel-services-logo-tile.png: Add arlo's services title icons. * libnautilus-extensions/Makefile.am: * libnautilus-extensions/nautilus-graphic.c: (nautilus_graphic_initialize_class), (nautilus_graphic_initialize), (nautilus_graphic_destroy), (nautilus_graphic_set_arg), (nautilus_graphic_get_arg), (nautilus_graphic_realize), (nautilus_graphic_unrealize), (nautilus_graphic_draw), (nautilus_graphic_size_allocate), (nautilus_graphic_size_request), (nautilus_graphic_map), (nautilus_graphic_unmap), (nautilus_graphic_expose), (ensure_buffer_size), (create_child_window), (nautilus_gdk_create_copy_area_gc), (nautilus_gdk_pixbuf_render_to_drawable), (nautilus_gdk_pixbuf_render_to_pixbuf), (nautilus_gdk_pixbuf_render_to_pixbuf_alpha), (gdk_string_dimensions), (nautilus_gdk_pixbuf_set_to_color), (nautilus_gdk_pixbuf_tile), (nautilus_gdk_pixbuf_tile_alpha), (nautilus_graphic_new), (nautilus_graphic_set_background_pixbuf), (nautilus_graphic_get_background_pixbuf), (nautilus_graphic_set_background_type), (nautilus_graphic_get_background_type), (nautilus_graphic_set_background_color), (nautilus_graphic_get_background_color), (nautilus_graphic_set_placement_type), (nautilus_graphic_get_placement_type), (nautilus_graphic_set_pixbuf), (nautilus_graphic_get_pixbuf), (nautilus_graphic_set_overall_alpha), (nautilus_graphic_set_label_text), (nautilus_graphic_get_label_text), (nautilus_graphic_set_label_font), (nautilus_graphic_get_label_font): * libnautilus-extensions/nautilus-graphic.h: Add NautilusGraphic widget to build. * test/.cvsignore: * test/Makefile.am: * test/test-nautilus-graphic.c: (create_background), (create_pixbuf), (create_graphic), (alpha_scale_value_changed), (red_color_value_changed), (green_color_value_changed), (blue_color_value_changed), (toggle_background_type_callback), (create_color_scale), (main): Add test for NautilusGraphic widget.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 8b5730ef8..8ea6825a3 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -35,6 +35,7 @@ noinst_PROGRAMS =\
test-nautilus-mime-actions-set \
test-nautilus-widgets \
test-nautilus-preferences \
+ test-nautilus-graphic \
$(NULL)
test_nautilus_mime_actions_SOURCES = test-nautilus-mime-actions.c
@@ -45,6 +46,8 @@ test_nautilus_widgets_SOURCES = test-nautilus-widgets.c
test_nautilus_preferences_SOURCES = test-nautilus-preferences.c
+test_nautilus_graphic_SOURCES = test-nautilus-graphic.c
+
#libleakcheck_la_SOURCES = \
# nautilus-leak-checker.c \
# nautilus-leak-checker.h \