summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am55
1 files changed, 50 insertions, 5 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index d2f55afd0..fd76d553b 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,18 +1,63 @@
NULL=
+@XML_I18N_MERGE_DESKTOP_RULE@
+@XML_I18N_MERGE_DIRECTORY_RULE@
+
+DESKTOP_IN_FILES= favorites.desktop.in \
+ programs.desktop.in \
+ starthere.desktop.in \
+ sysconfig.desktop.in \
+ preferences.desktop.in \
+ serverconfig.desktop.in \
+ starthere-link.desktop.in \
+ $(NULL)
+
+DIRECTORY_IN_FILES= serverconfig.directory.in \
+ starthere.directory.in \
+ sysconfig.directory.in \
+ $(NULL)
+
+DESKTOP_FILES=$(DESKTOP_IN_FILES:.desktop.in=.desktop)
+DIRECTORY_FILES=$(DIRECTORY_IN_FILES:.directory.in=.directory)
+
+startheredir= $(sysconfdir)/X11/starthere
+starthere_DATA= favorites.desktop \
+ programs.desktop \
+ sysconfig.desktop \
+ preferences.desktop \
+ serverconfig.desktop \
+ $(NULL)
+
+DESKTOP_FILES=$(DESKTOP_IN_FILES:.in=)
+
nautilusdatadir = $(datadir)/nautilus
nautilusdata_DATA = \
- browser.xml \
- static_bookmarks.xml \
- nautilus-extras.placeholder \
- nautilus-suggested.placeholder \
+ browser.xml \
+ static_bookmarks.xml \
+ nautilus-extras.placeholder \
+ nautilus-suggested.placeholder \
+ starthere.desktop \
+ starthere-link.desktop \
$(NULL)
-EXTRA_DIST = $(nautilusdata_DATA)
+EXTRA_DIST = $(nautilusdata_DATA) \
+ $(DESKTOP_IN_FILES) \
+ $(DESKTOP_FILES) \
+ $(DIRECTORY_IN_FILES) \
+ $(DIRECTORY_FILES) \
+ $(NULL)
SUBDIRS = \
emblems \
linksets \
patterns \
$(NULL)
+
+install-data-local: $(DIRECTORY_FILES)
+ $(mkinstalldirs) $(sysconfdir)/X11/starthere
+ $(mkinstalldirs) $(sysconfdir)/X11/starthere/sysconfig
+ $(mkinstalldirs) $(sysconfdir)/X11/starthere/serverconfig
+ $(INSTALL_DATA) starthere.directory $(sysconfdir)/X11/starthere/.directory
+ $(INSTALL_DATA) sysconfig.directory $(sysconfdir)/X11/starthere/sysconfig/.directory
+ $(INSTALL_DATA) serverconfig.directory $(sysconfdir)/X11/starthere/serverconfig/.directory