summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index f2cfb7d3e..470ee039e 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,7 +1,24 @@
-NULL=
+include $(top_srcdir)/Makefile.shared
SUBDIRS = icons
+AM_CPPFLAGS=\
+ $(COMMON_CFLAGS) \
+ $(NULL)
+
+noinst_PROGRAMS= \
+ lineup-parameters \
+ $(NULL)
+
+lineup_parameters_SOURCES= \
+ lineup-parameters.c \
+ $(NULL)
+
+lineup_parameters_LDADD= \
+ $(CORE_LIBS) \
+ $(COMMON_LIBS) \
+ $(NULL)
+
desktopdir = $(datadir)/applications
desktop_in_files = \
org.gnome.Nautilus.desktop.in \
@@ -66,11 +83,11 @@ CLEANFILES = \
$(desktop_DATA) \
$(service_DATA) \
$(appdata_DATA) \
+ $(noinst_PROGRAMS) \
$(NULL)
if ENABLE_DESKTOP
CLEANFILES += $(autostart_DATA)
endif
-
-include $(top_srcdir)/git.mk