summaryrefslogtreecommitdiff
path: root/docs/reference/libnautilus-extension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/libnautilus-extension/Makefile.am')
-rw-r--r--docs/reference/libnautilus-extension/Makefile.am74
1 files changed, 74 insertions, 0 deletions
diff --git a/docs/reference/libnautilus-extension/Makefile.am b/docs/reference/libnautilus-extension/Makefile.am
new file mode 100644
index 000000000..8e2b48ad1
--- /dev/null
+++ b/docs/reference/libnautilus-extension/Makefile.am
@@ -0,0 +1,74 @@
+## Process this file with automake to produce Makefile.in
+
+# We require automake 1.6 at least.
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module, e.g. 'glib'.
+DOC_MODULE=libnautilus-extension
+
+# The top-level SGML file. You can change this if you want to.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting the functions and macros.
+# e.g. DOC_SOURCE_DIR=../../../libnautilus-extension
+DOC_SOURCE_DIR=$(top_srcdir)/libnautilus-extension
+
+# Extra options to pass to gtkdoc-scangobj. Not normally needed.
+SCANGOBJ_OPTIONS=--type-init-func="g_type_init()"
+
+# Extra options to supply to gtkdoc-scan.
+# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
+SCAN_OPTIONS=--deprecated-guards="G_DISABLE_DEPRECATED"
+
+# Extra options to supply to gtkdoc-mkdb.
+# e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-mktmpl
+# e.g. MKTMPL_OPTIONS=--only-section-tmpl
+MKTMPL_OPTIONS=
+
+# Extra options to supply to gtkdoc-fixref. Not normally needed.
+# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
+FIXXREF_OPTIONS=
+
+HFILE_GLOB=$(top_srcdir)/libnautilus-extension/*.h
+CFILE_GLOB=$(top_srcdir)/libnautilus-extension/*.c
+
+IGNORE_HFILES= \
+ $(NULL)
+
+EXTRA_HFILES= \
+ $(NULL)
+
+HTML_IMAGES=
+
+content_files= \
+ version.xml \
+ $(NULL)
+
+# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
+# These files must be listed here *and* in content_files
+# e.g. expand_content_files=running.sgml
+expand_content_files= \
+ $(NULL)
+
+# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
+# Only needed if you are using gtkdoc-scangobj to dynamically query widget
+# signals and properties.
+# e.g. INCLUDES=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
+# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
+
+INCLUDES=-I$(top_srcdir) $(CORE_CFLAGS)
+GTKDOC_LIBS= -L$(top_builddir) $(CORE_LIBS) \
+ $(top_builddir)/libnautilus-extension/libnautilus-extension.la \
+ $(NULL)
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+# e.g. EXTRA_DIST += version.xml.in
+EXTRA_DIST += version.xml.in