summaryrefslogtreecommitdiff
path: root/docs/reference/libnautilus-extension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/libnautilus-extension/Makefile.am')
-rw-r--r--docs/reference/libnautilus-extension/Makefile.am78
1 files changed, 0 insertions, 78 deletions
diff --git a/docs/reference/libnautilus-extension/Makefile.am b/docs/reference/libnautilus-extension/Makefile.am
deleted file mode 100644
index c321908ba..000000000
--- a/docs/reference/libnautilus-extension/Makefile.am
+++ /dev/null
@@ -1,78 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-# We require automake 1.6 at least.
-AUTOMAKE_OPTIONS = 1.6
-
-# The name of the module, e.g. 'glib'.
-DOC_MODULE=libnautilus-extension
-
-# The top-level SGML file.
-DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
-
-SCAN_OPTIONS=--rebuild-types
-
-# The directory containing the source code. Relative to $(srcdir).
-# gtk-doc will search all .c & .h files beneath here for inline comments
-# documenting the functions and macros.
-# e.g. DOC_SOURCE_DIR=../../../libnautilus-extension
-DOC_SOURCE_DIR=$(top_srcdir)/libnautilus-extension
-
-# Extra options to supply to gtkdoc-mkdb.
-MKDB_OPTIONS=--sgml-mode --output-format=xml
-
-# Extra options to supply to gtkdoc-mktmpl
-# e.g. MKTMPL_OPTIONS=--only-section-tmpl
-MKTMPL_OPTIONS=
-
-# Extra options to supply to gtkdoc-fixref. Not normally needed.
-# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
-FIXXREF_OPTIONS=
-
-# Used for dependencies. The docs will be rebuilt if any of these change.
-HFILE_GLOB=$(top_srcdir)/libnautilus-extension/*.h
-CFILE_GLOB=$(top_srcdir)/libnautilus-extension/*.c
-
-# Header files to ignore when scanning.
-IGNORE_HFILES = \
- nautilus-extension-private.h \
- $(NULL)
-
-# Images to copy into HTML directory
-HTML_IMAGES =
-
-content_files = \
- version.xml \
- $(NULL)
-
-# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
-# These files must be listed here *and* in content_files
-# e.g. expand_content_files=running.sgml
-expand_content_files= \
- $(NULL)
-
-# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
-# Only needed if you are using gtkdoc-scangobj to dynamically query widget
-# signals and properties.
-# e.g. INCLUDES=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
-# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
-GTKDOC_CFLAGS = \
- $(GTK_DEBUG_FLAGS) \
- -I$(srcdir) \
- -I$(top_srcdir) \
- -I$(top_srcdir)/libnautilus-extension \
- -I$(top_builddir) \
- -I$(top_builddir)/libnautilus-extension \
- $(BASE_CFLAGS) \
- $(NULL)
-
-GTKDOC_LIBS = \
- $(top_builddir)/libnautilus-extension/libnautilus-extension.la \
- $(BASE_LIBS) \
- $(NULL)
-
-# This includes the standard gtk-doc make rules, copied by gtkdocize.
-include $(top_srcdir)/gtk-doc.make
-
-# Other files to distribute
-# e.g. EXTRA_DIST += version.xml.in
-EXTRA_DIST += version.xml.in