summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 784a6f714..7bbf38b8f 100644
--- a/meson.build
+++ b/meson.build
@@ -40,6 +40,7 @@ add_project_arguments(
'-Werror=undef',
'-Werror=uninitialized',
]),
+ '-D_GNU_SOURCE',
language: 'c'
)
@@ -129,7 +130,6 @@ conf.set_quoted('NAME_SUFFIX', name_suffix)
#
# gnome-desktop macros for thumbnailer sandboxing.
####################################
-conf.set10('_GNU_SOURCE', true) # `man user_namespaces` /CLONE_NEWUSER
if is_linux
conf.set10('ENABLE_SECCOMP', true)
conf.set10('HAVE_BWRAP', true)
@@ -181,4 +181,4 @@ if get_option('extensions')
endif
# Compile GSettings schemas when installing from source.
-meson.add_install_script('build-aux/meson/postinstall.py')
+meson.add_install_script('build-aux/meson/postinstall.py') \ No newline at end of file