summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 85c3cb9da..4160c8fe0 100644
--- a/meson.build
+++ b/meson.build
@@ -81,9 +81,13 @@ if get_option ('enable-selinux')
conf.set10 ('HAVE_SELINUX', true)
endif
-if get_option ('enable-tracker')
- tracker_sparql = dependency ('tracker-sparql-2.0')
- conf.set10 ('ENABLE_TRACKER', true)
+tracker_option = get_option ('enable-tracker')
+if tracker_option != 'no'
+ tracker_sparql = dependency ('tracker-sparql-2.0', required: (tracker_option == 'yes'))
+ if not tracker_sparql.found()
+ tracker_sparql = dependency ('tracker-sparql-1.0', required: (tracker_option == 'yes'))
+ endif
+ conf.set10 ('ENABLE_TRACKER', tracker_sparql.found())
endif
if get_option ('enable-xmp')