summaryrefslogtreecommitdiff
path: root/test/automated/displayless/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/automated/displayless/meson.build')
-rw-r--r--test/automated/displayless/meson.build32
1 files changed, 29 insertions, 3 deletions
diff --git a/test/automated/displayless/meson.build b/test/automated/displayless/meson.build
index eecc1f406..64b23bd2a 100644
--- a/test/automated/displayless/meson.build
+++ b/test/automated/displayless/meson.build
@@ -1,3 +1,7 @@
+trackertestutils = dependency('tracker-testutils-3.0')
+
+tracker_sandbox = find_program(trackertestutils.get_pkgconfig_variable('command'))
+
tests = [
['test-file-utilities-get-common-filename-prefix', [
'test-file-utilities-get-common-filename-prefix.c'
@@ -23,9 +27,6 @@ tests = [
['test-nautilus-search-engine-model', [
'test-nautilus-search-engine-model.c'
]],
- ['test-nautilus-search-engine-tracker', [
- 'test-nautilus-search-engine-tracker.c'
- ]],
['test-file-operations-copy-files', [
'test-file-operations-copy-files.c'
]],
@@ -34,6 +35,12 @@ tests = [
]]
]
+tracker_tests = [
+ ['test-nautilus-search-engine-tracker', [
+ 'test-nautilus-search-engine-tracker.c',
+ ]],
+]
+
foreach t: tests
test(
t[0],
@@ -46,3 +53,22 @@ foreach t: tests
timeout: 480
)
endforeach
+
+
+
+# Tests that read and write from the Tracker index are run using 'tracker-sandbox'
+# script to use a temporary instance of tracker-miner-fs instead of the session one.
+foreach t: tracker_tests
+ test_exe = executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep)
+ test(
+ t[0],
+ tracker_sandbox,
+ args: ['--store-tmpdir', '--index-recursive-tmpdir', test_exe],
+ env: [
+ test_env,
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+ ],
+ timeout: 480
+ )
+endforeach