summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* canvas-container: take the canvas icon size into account for icon sizewip/gaction_Cosimo Cecchi2015-01-221-3/+8
| | | | | | When scaling the icon size with the grid unit, take the nominal icon size into account too, since the actual icon we get back might be smaller than that - e.g. if we have a narrow thumbnail with little text.
* canvas-item: change the maximum text size at standard zoomCosimo Cecchi2015-01-221-4/+5
| | | | To match mockups.
* canvas-container: add a comment to explain STANDARD_ICON_GRID_WIDTHCosimo Cecchi2015-01-221-0/+7
| | | | This constant is very important and needs explaining.
* canvas-item: remove useless checkCosimo Cecchi2015-01-221-6/+2
| | | | The max text width is always > 0.
* canvas-container: formatting cleanupsCosimo Cecchi2015-01-221-4/+4
|
* theme: add theming for selected dim labels for canvas itemsCosimo Cecchi2015-01-221-0/+4
|
* canvas-item: fix an incorrect commentCosimo Cecchi2015-01-211-1/+1
| | | | This size is based off the NAUTILUS_CANVAS_ICON_SIZE_STANDARD icon size.
* canvas-container: remove an always true parameterCosimo Cecchi2015-01-211-17/+14
|
* canvas-container: remove unused defineCosimo Cecchi2015-01-211-2/+0
|
* theme: add a style for dim-label canvas item labelsCosimo Cecchi2015-01-211-0/+4
|
* canvas-view-container: remove unused definesCosimo Cecchi2015-01-211-3/+0
|
* canvas-view-container: change icon captions logicCosimo Cecchi2015-01-211-2/+2
| | | | | We now can show one caption at small zoom, two at normal and three at maximum zoom. The default is to show no captions.
* canvas-view-container: don't cache icon captions attributesCosimo Cecchi2015-01-211-26/+14
| | | | This will lead the code to caching the wrong value.
* view: fix possibly uninitialized variableCosimo Cecchi2015-01-211-0/+1
|
* view: code formattingCosimo Cecchi2015-01-211-6/+3
|
* view: plug some memory leaksCosimo Cecchi2015-01-211-0/+3
|
* view: remove unused variableCosimo Cecchi2015-01-211-4/+0
|
* view: refactor code to add extension actionCosimo Cecchi2015-01-211-87/+95
| | | | | Make this simpler to follow. Also handle the case where a submenu defines an item with the same name as one of the above menus.
* nautilus-view: Make actions name of extensions uniqueCarlos Soriano2015-01-211-82/+59
| | | | | | Make sure that, although extensions can use the same action name, they are unique appending the index of the extension to the action name plus the menu name.
* view: refactor extension GMenu codeCosimo Cecchi2015-01-211-47/+45
| | | | Plug a lot of leaks along the way, and make this code a bit simpler.
* view: don't re-validate extension action nameCosimo Cecchi2015-01-211-61/+1
| | | | This doesn't look like it's needed.
* view: fix a typoCosimo Cecchi2015-01-211-1/+1
| | | | Background items are meant to go in the background menu.
* view: use library method to free NautilusMenuItemsCosimo Cecchi2015-01-211-13/+4
| | | | For clarity.
* ui-utilities: plug some memory leaksCosimo Cecchi2015-01-211-1/+9
|
* Formatting cleanupsCosimo Cecchi2015-01-213-9/+12
|
* search-directory: remove leftovers of saved search APIsCosimo Cecchi2015-01-213-18/+0
|
* view: fix some warningsCosimo Cecchi2015-01-211-5/+4
|
* view: cleanup zoom-to-level actionsCosimo Cecchi2015-01-214-100/+55
| | | | | Instead of putting it in the superclass, have the subclasses implement it individually.
* Remove saved search mimetype associationCosimo Cecchi2015-01-212-27/+1
| | | | It's not used anymore.
* general: Implement extensions for GActionCarlos Soriano2015-01-212-0/+291
| | | | | | | | | | | | The last commit rework the menus and ported to GAction. Update the extension mechanism to that. The changes are very little. Now menu items in extensions lost the property 'priority' since gmenu doesn't have one, and gain two properties, menu_name, which is in which menu do you want the extension to add a menu item, it can be background or selection, and menu_section, which indicates in which section of the menu do you want to add the items of the extension.
* general: rework menus of nautilusCarlos Soriano2015-01-2129-4135/+3106
| | | | | | | | | Refresh the nautilus menus in the view (context menus) and the menus in the toolbar, changin as well in the path the UI of the toolbar to match mockups. In the way, port to GAction and GMenu every action and menu of nautilus and some clean ups thanks to this port.
* nautilus-view: rename location to pathbar for clarityCarlos Soriano2015-01-213-40/+43
| | | | | Nane the pathbar actions "location" is confusing. Instead rename it to pathbar.
* nautilus-view: move function for better contextCarlos Soriano2015-01-211-38/+37
|
* nautilus-view: drop some pathbar menusCarlos Soriano2015-01-213-540/+0
| | | | | Having some items like cut and paste on the pathbar looks odd. Instead, just let open in new tab, open in new window and properties.
* nautilus-view: drop empty trash on viewCarlos Soriano2015-01-213-31/+0
| | | | | | | | When the user is in the trash, there's already a inapp dialog that shows a button to empty the trash. On the other hand the sidebar also shows this item. Since it's not expected the user to see the trash directly as a folder, drop this item from the menus.
* nautilus-view: drop self actionsCarlos Soriano2015-01-213-302/+1
| | | | | | Mounting or unmounting the drive associated to the folder the user is currently viewing is confusing and probably unwanted. Drop it.
* nautilus-view: drop save searchCarlos Soriano2015-01-216-251/+2
| | | | | | | Seacrhing normally is a matter of just typing at the moment what you want to search. Probably saving a search and opening it again is more time cost and a burden than just type what you want to search. So drop this action.
* eautilus-view: drop create linkCarlos Soriano2015-01-213-106/+0
| | | | | | The ui won't offer a way to do it since it's an action that probably most of users won't even know what a link is, and those who need it probably can use other ways to manage these kind of actions.
* nautilus-view: drop reset to defaultsCarlos Soriano2015-01-217-111/+0
| | | | | With the upcomming UI rework the user won't need to reset to defaults, since the UI will be straighforward and not need to this item.
* nautilus-icon-info: rework zoom levelsCarlos Soriano2015-01-2123-320/+196
| | | | | | | | | | Following a design request and preparing to the port to popovers of nautilus, we want to use only 3 zoom levels for each kind of view, so the slider makes sense. Also, following design guidelines, the new zoom levels sizes for icon view are 64, 96, 128, with default to 96 and 16, 32, 48 for list view, 32 being the default
* nautilus-view: drop unused parameterCarlos Soriano2015-01-211-4/+2
|
* nautilus-view: remove wrong commentCarlos Soriano2015-01-211-3/+1
|
* nautilus-view: remove wrong commentCarlos Soriano2015-01-211-2/+0
|
* Updated Czech translationMarek Černocký2015-01-211-819/+691
|
* window: fix GCC warningCosimo Cecchi2015-01-201-1/+1
|
* preferences: Expand tabsCarlos Soriano2015-01-201-0/+7
| | | | Following design guidelines
* Updated Spanish translationDaniel Mustieles2015-01-201-817/+785
|
* Rename Location to Parent Folder - bug #47678Robert Roth2015-01-201-1/+1
|
* column-chooser: also move "Reset to Defaults" to the toolbarCosimo Cecchi2015-01-192-46/+53
|
* Move the up/down buttons to inline toolbar - bug #674142Robert Roth2015-01-191-30/+46
|