summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1105fb6..4d8ca16b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -420,6 +420,7 @@ if(WIN32 OR WINCE)
endif(HAVE_WINSOCK)
if(MSVC)
+ set(HAVE_PRAGMA_PACK 1)
add_plugin(support/xgetopt "Windows detected" TRUE)
set(ENABLE_NLS FALSE)
else(MSVC)
@@ -430,6 +431,7 @@ if(WIN32 OR WINCE)
set(XSLTS "windows;${XSLTS}" CACHE STRING "define a semicolon seperated list of XSLTs to process")
endif()
if (WIN32 AND NOT WINCE)
+ set(HAVE_PRAGMA_PACK 1)
set(HAVE_API_WIN32 1)
set(HAVE_STDINT_H 1)
#set(BUILD_MAPTOOL FALSE)
@@ -438,6 +440,7 @@ if (WIN32 AND NOT WINCE)
endif()
if(WINCE)
add_plugin(support/libc "wince detected" TRUE)
+ set(HAVE_PRAGMA_PACK 1)
set(HAVE_API_WIN32_CE 1)
set(BUILD_MAPTOOL FALSE)
set_with_reason(vehicle/file "wince: currently broken" FALSE)