summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61e279ee..6d52c539 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -420,6 +420,14 @@ if(XSLT_PROCESSOR)
if (NOT SAXON_ERROR)
set (XSLT_PROCESSOR_OPTIONS -snone)
endif()
+ # additional parameter is passed to the stylesheet processor as transformation parameter
+ macro(compose_xslt_transform_command CMDVAR XSLT_FILE SRC_XML DEST_XML)
+ if(${XSLT_PROCESSOR} MATCHES "xsltproc")
+ set(${CMDVAR} COMMAND ${XSLT_PROCESSOR} ${XSLT_PROCESSOR_OPTIONS} ${XSLT_FILE} ${SRC_XML} >${DEST_XML})
+ else()
+ set(${CMDVAR} COMMAND ${XSLT_PROCESSOR} ${XSLT_PROCESSOR_OPTIONS} ${SRC_XML} ${XSLT_FILE} ${ARGN} >${DEST_XML})
+ endif()
+ endmacro()
else()
cfg_feature(XSL_PROCESSING "Saxon missing" FALSE)
endif(XSLT_PROCESSOR)