summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorrikky <rikky@ffa7fe5e-494d-0410-b361-a75ebd5db220>2012-05-31 21:17:36 +0000
committerrikky <rikky@ffa7fe5e-494d-0410-b361-a75ebd5db220>2012-05-31 21:17:36 +0000
commit1a2cc58a5dca20b3f73735547c09f7881b389cb1 (patch)
tree3c382c4daba1ebeac4e9c03916cf4afb26120c43 /CMakeLists.txt
parent7d8236deddfc2a5242459253457532497ae45d36 (diff)
downloadnavit-1a2cc58a5dca20b3f73735547c09f7881b389cb1.tar.gz
Fix:build:Workaround for android build with older NDKs
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5125 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index deae6a159..ab67d0e83 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,8 +171,10 @@ else()
endif(NOT HAVE_LIBINTL)
-if (CMAKE_USE_PTHREADS_INIT)
- list(APPEND NAVIT_LIBS pthread)
+if (CMAKE_USE_PTHREADS_INIT)
+ if (NOT ANDROID)
+ list(APPEND NAVIT_LIBS pthread)
+ endif(NOT ANDROID)
endif(CMAKE_USE_PTHREADS_INIT)
if (Glib_FOUND)
set(HAVE_GLIB 1)