summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-02-15 22:16:02 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-02-15 22:16:02 +0000
commit8c21202e3720dbc4284f25fba4965ac1f3e575fb (patch)
tree71f3ea1fc87ef51ded9d6c8377796a3b07ef1841 /CMakeLists.txt
parent71251f4acdd831f062b9f091a4611bd4772de953 (diff)
downloadnavit-8c21202e3720dbc4284f25fba4965ac1f3e575fb.tar.gz
Fix:Build:Add imlib2 check to cmake
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5377 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1a327266..043b7b27f 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,6 +134,10 @@ if(PKG_CONFIG_FOUND)
pkg_check_modules(LIBOSSO libosso)
pkg_check_modules(LIBGPS19 libgps>=2.90)
pkg_check_modules(LIBGARMIN libgarmin)
+ pkg_check_modules(IMLIB2 imlib2)
+ if(IMLIB2_FOUND)
+ set(HAVE_IMLIB2 1)
+ endif(IMLIB2_FOUND)
endif(PKG_CONFIG_FOUND)
#Simple checks
CHECK_INCLUDE_FILES(wordexp.h HAVE_WORDEXP)