summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorrikky <rikky@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-01-24 14:49:57 +0000
committerrikky <rikky@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-01-24 14:49:57 +0000
commit70dbd333a65a6faa0d0b97faf2cb23f6cba95436 (patch)
tree907ccb94e362ce126e8fde3b0343a7247bff233b /CMakeLists.txt
parentc4a2a4453ddc1e9d90c69dc25abda74b9d8333d8 (diff)
downloadnavit-70dbd333a65a6faa0d0b97faf2cb23f6cba95436.tar.gz
Add:Build/cmake:Check for memalign, valloc and posix_memalign to improve memory managment for some embedded devices
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@3959 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65a18ba01..eeab2ef1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,8 +84,8 @@ CHECK_INCLUDE_FILES(stdint.h HAVE_STDINT_H)
CHECK_INCLUDE_FILES(byteswap.h HAVE_BYTESWAP_H)
CHECK_LIBRARY_EXISTS(gypsy gypsy_control_get_default "" GYPSY_FOUND)
CHECK_INCLUDE_FILES(libspeechd.h HAVE_LIBSPEECHD)
-
CHECK_INCLUDE_FILES(sys/socket.h HAVE_SOCKET)
+
### Configure build
#Required libraries, supplied with navit
if (Glib_FOUND)
@@ -417,6 +417,9 @@ CHECK_INCLUDE_FILES (malloc.h HAVE_MALLOC_H)
CHECK_INCLUDE_FILES ("sys/param.h;sys/mount.h" HAVE_SYS_MOUNT_H)
CHECK_INCLUDE_FILES (unistd.h HAVE_UNISTD_H)
CHECK_FUNCTION_EXISTS (getcwd HAVE_GETCWD)
+CHECK_FUNCTION_EXISTS (memalign HAVE_MEMALIGN)
+CHECK_FUNCTION_EXISTS (valloc HAVE_VALLOC)
+CHECK_FUNCTION_EXISTS (posix_memalign HAVE_POSIX_MEMALIGN)
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)