summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2014-03-28 20:20:05 +0000
committermdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2014-03-28 20:20:05 +0000
commit547946b09e32ff3708d39119ea822c116ae86816 (patch)
tree8ef025e908c14b33548571b3089b9d01c90a4e6f /CMakeLists.txt
parentf3c12adb744d1455c7e8642777f12ab3b740886b (diff)
downloadnavit-547946b09e32ff3708d39119ea822c116ae86816.tar.gz
Fix:port_wince:Partially revert r5746 to allow cmake wince builds with gcc versions >5.7.0
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5761 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3833ba14c..bb3e3e01c 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -527,6 +527,8 @@ if(WINCE)
add_plugin(support/libc "wince detected" TRUE)
set(HAVE_API_WIN32_CE 1)
set(BUILD_MAPTOOL FALSE)
+ # mingw32ce since gcc 4.7.0 needs HAVE_PRAGMA_PACK as __attribute__((packed)) is broken, see gcc bug 52991
+ set(HAVE_PRAGMA_PACK 1)
set_with_reason(vehicle/file "wince: currently broken" FALSE)
set_with_reason(vehicle/wince "wince detected" TRUE)
endif()