summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2012-01-18 21:11:59 +0000
committermdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2012-01-18 21:11:59 +0000
commitd0bfd98ef67f156c116e924e835587e9b2d320b7 (patch)
tree759e80ec3a8bf194b72de75919d2aba003818e94 /CMakeLists.txt
parent8a4924c34d2d4c4699dee43530b0348d116c6d5b (diff)
downloadnavit-d0bfd98ef67f156c116e924e835587e9b2d320b7.tar.gz
Add:core:New binding_win32 module for Windows and WinCE. Some details are at ticket #970.
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4892 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b82367c4d..83cad502d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,6 +62,7 @@ add_module(gui/gtk "GTK libs not found" FALSE)
add_module(vehicle/gpsd "gpsd lib not found" FALSE)
add_module(vehicle/gypsy "gypsy lib not found" FALSE)
add_module(vehicle/maemo "Default" FALSE)
+add_module(binding/win32 "Default" FALSE)
add_module(binding/dbus "dbus-glib-1 not found" FALSE)
add_module(speech/dbus "dbus-glib-1 not found" FALSE)
add_module(speech/cmdline "neither system() nor CreateProcess() found" FALSE)
@@ -388,6 +389,7 @@ if(WIN32 OR WINCE)
set_with_reason(support/ezxml "Windows detected" TRUE)
set_with_reason(speech/espeak "Windows detected" TRUE)
set_with_reason(support/espeak "Windows detected" TRUE)
+ set_with_reason(binding/win32 "Windows detected" TRUE)
# vehicle_file is broken for windows. use vehicle_wince instead
# whicle_wince isn't buildable on non-CE windows ssytems