summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2012-03-04 08:48:50 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2012-03-04 08:48:50 +0000
commit6a0ba2bdb6d21185fe4baff48805821ea069fe18 (patch)
tree9d6ed7861f197841c9b3186b332ee843dc9249d4 /CMakeLists.txt
parent8d42bcbce304868bcd6df03e5b7596ff969c0c17 (diff)
downloadnavit-6a0ba2bdb6d21185fe4baff48805821ea069fe18.tar.gz
Add:Build:Cmake-Options for OpenGLES and OpenGLES2
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4960 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt16
1 files changed, 13 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a69b93b6..4c7298008 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -238,11 +238,21 @@ if(GTK2_FOUND)
endif(GTK2_FOUND)
CHECK_LIBRARY_EXISTS(freeimage FreeImage_Load "" HAVE_FREEIMAGE)
+if (USE_OPENGLES OR USE_OPENGLES2)
+ CHECK_LIBRARY_EXISTS(EGL eglInitialize "" HAVE_EGL)
+endif(USE_OPENGLES OR USE_OPENGLES2)
if (FREETYPE_FOUND)
if (OPENGL_FOUND AND OPENGL_GLU_FOUND AND GLUT_FOUND AND OPENGL_INCLUDE_DIR)
message (STATUS "opengl found: ${OPENGL_gl_LIBRARY}")
include_directories(${OPENGL_INCLUDE_DIR})
- set(GRAPHICS_OPENGL_LIBRARY ${OPENGL_gl_LIBRARY};${OPENGL_glu_LIBRARY};${GLUT_glut_LIBRARY})
+ if (USE_OPENGLES2)
+ set(USE_OPENGLES TRUE)
+ set(GRAPHICS_OPENGL_LIBRARY GLESv2 EGL)
+ elseif (USE_OPENGLES)
+ set(GRAPHICS_OPENGL_LIBRARY GLESv1_CM EGL)
+ else()
+ set(GRAPHICS_OPENGL_LIBRARY ${OPENGL_gl_LIBRARY};${OPENGL_glu_LIBRARY};${GLUT_glut_LIBRARY})
+ endif(USE_OPENGLES2)
if (HAVE_FREEIMAGE)
list(APPEND GRAPHICS_OPENGL_LIBRARY freeimage)
endif(HAVE_FREEIMAGE)
@@ -251,8 +261,8 @@ if (FREETYPE_FOUND)
message (STATUS "opengl not found")
endif()
else()
- message (STATUS "no glc implementation found. Install Quesoglc for OpenGL support")
-endif(QUESOGLC_FOUND AND FREETYPE_FOUND)
+ message (STATUS "no Freetype found")
+endif(FREETYPE_FOUND)
if(SDL_FOUND AND SDLIMAGE_FOUND AND FREETYPE_FOUND)
set(SDL_IMAGE 1)