summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-03-18 08:40:53 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-03-18 08:40:53 +0000
commita5978d1e28c6ef9384e1f73a0a02e4ea8f13d5c1 (patch)
tree7c715a8b6dd1656264a279cc3fb105573c2cbb52 /configure.in
parentb061c3e1eb59b18cd36f62d34a511eb69ea21943 (diff)
downloadnavit-a5978d1e28c6ef9384e1f73a0a02e4ea8f13d5c1.tar.gz
Fix:Android:Dirty fix to workaround shared library loading problems on htc hero
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@3042 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f9beee87d..41b1abe0d 100644
--- a/configure.in
+++ b/configure.in
@@ -71,6 +71,7 @@ graphics_android=no; graphics_android_reason=default
vehicle_maemo=no; vehicle_maemo_reason=default
shared_libnavit=no
+LIBNAVIT=navit
bin_navit=yes
AC_CANONICAL_HOST
@@ -110,7 +111,8 @@ linux*_android)
speech_android=yes; speech_android_reason="host_os is android"
MODULE_LDFLAGS="-module -Xcompiler -nostdlib -Xcompiler -Wl,-rpath -Xcompiler -Wl,/data/data/org.navitproject.navit/lib"
MODULE_LIBADD="-llog"
- NAVIT_MODULE_LDFLAGS="$MODULE_LDFLAGS -L\$(top_builddir)/navit -lnavit"
+ LIBNAVIT=_data_data_org.navitproject.navit_lib_navit
+ NAVIT_MODULE_LDFLAGS="$MODULE_LDFLAGS -L\$(top_builddir)/navit -l$LIBNAVIT"
;;
esac
if test "x$win32" = "xyes"
@@ -274,7 +276,7 @@ if test "x${plugins}" = "xyes"; then
)
if test "x${win32}" = "xyes"; then
shared_libnavit=yes
- NAVIT_MODULE_LDFLAGS="-no-undefined -L\$(top_builddir)/navit -lnavit -L\$(top_builddir)/intl -lintl"
+ NAVIT_MODULE_LDFLAGS="-no-undefined -L\$(top_builddir)/navit -l$LIBNAVIT -L\$(top_builddir)/intl -lintl"
fi
else
AC_DISABLE_SHARED
@@ -284,6 +286,7 @@ AM_CONDITIONAL(PLUGINS, [test "x$plugins" = "xyes"])
AM_CONDITIONAL(SHARED_LIBNAVIT, [test "x$shared_libnavit" = "xyes"])
AM_CONDITIONAL(BIN_NAVIT, [test "x$bin_navit" = "xyes"])
AC_PROG_LIBTOOL
+AC_SUBST(LIBNAVIT)
AM_CONDITIONAL(EVENT_GLIB, [test "x$glib" = "xyes"])
AM_CONDITIONAL(SUPPORT_GLIB, [test "x$glib" = "xno"])