summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkazer_ <kazer_@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-06-22 10:08:58 +0000
committerkazer_ <kazer_@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-06-22 10:08:58 +0000
commit3dbcadf3ad166ccb972625021b61dc9c399e5b2c (patch)
treec497a3c97160164a8aff88b851d8472726e7dfa9 /configure.in
parent9272ea906bc7b33a6bb6561921d9078a289b2e3b (diff)
downloadnavit-3dbcadf3ad166ccb972625021b61dc9c399e5b2c.tar.gz
Fix:configure:Possible fix for broken QtSvg check
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@3375 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3c0e1c98f..3e345c0c0 100644
--- a/configure.in
+++ b/configure.in
@@ -840,12 +840,14 @@ AM_CONDITIONAL(GRAPHICS_WIN32, test "x${graphics_win32}" = "xyes")
AC_ARG_ENABLE(graphics-qt-qpainter, [ --disable-graphics-qt-qpainter disable graphics type qt-qpainter], graphics_qt_qpainter=$enableval;graphics_qt_qpainter_reason="configure parameter")
if test "x${graphics_qt_qpainter}" = "xyes" -a "x${QT_GUI_CFLAGS}" = "x" -a "x${QT_GUI_LIBS}" = "x"; then
PKG_CHECK_MODULES(QT_GUI, [QtGui QtCore], ,graphics_qt_qpainter=no,graphics_qt_qpainter_reason="Packages QtGui and/or QtCore missing")
- PKG_CHECK_MODULES(QT_SVG, [QtSvg], ,graphics_qt_qpainter=no,graphics_qt_qpainter_reason="Package QtSvg missing")
if test "x${graphics_qt_qpainter}" = "xno"; then
PKG_CHECK_MODULES(QT_GUI, [qt-mt],graphics_qt_qpainter=yes,graphics_qt_qpainter_reason="Package qt-mt present")
fi
fi
if test "x${graphics_qt_qpainter}" = "xyes" ; then
+ PKG_CHECK_MODULES(QT_SVG, [QtSvg], ,graphics_qt_qpainter=no,graphics_qt_qpainter_reason="Package QtSvg missing")
+fi
+if test "x${graphics_qt_qpainter}" = "xyes" ; then
AC_DEFINE(USE_GRAPICS_QT_QPAINTER, 1, [Build with graphics qt_qpainter])
MOC=`$PKG_CONFIG QtGui --variable=moc_location`
if test "x${MOC}" = "x"; then