summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-06-29 18:22:46 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-06-29 18:22:46 +0000
commit1176e730b4a1e16354334dd16f32abf8d18e8a56 (patch)
tree31471a6a1e1e4b91305edeaeedb12e95c8f4bae1 /configure.in
parent1512617f5e228a857b6b21eab302a7a62f7be9b6 (diff)
downloadnavit-1176e730b4a1e16354334dd16f32abf8d18e8a56.tar.gz
Add:Configure parameter for maptool
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@3450 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f9d734273..cfcc31b43 100644
--- a/configure.in
+++ b/configure.in
@@ -54,6 +54,7 @@ graphics_null=yes; graphics_null_reason=default
graphics_opengl=yes; graphics_opengl_reason=default
graphics_sdl=yes; graphics_sdl_reason=default
graphics_win32=no; graphics_win32_reason=default
+maptool=yes; maptool_reason=default
map_binfile=yes; map_binfile_reason=default
map_filter=yes; map_filter_reason=default
map_mg=yes; map_mg_reason=default
@@ -251,6 +252,11 @@ AC_PATH_PROG(_PATH_BZCAT,[bzcat])
if test "x${_PATH_BZCAT}" = "x" ; then
samplemap=no; samplemap_reason="bzcat missing"
fi
+AC_ARG_ENABLE(maptool, [ --disable-maptool don't build maptool], maptool=$enableval;maptool_reason="configure parameter")
+AM_CONDITIONAL(MAPTOOL, [test "x$maptool" = "xyes"])
+if test "x$maptool" != "xyes"; then
+ samplemap=no; samplemap_reason="maptool disabled"
+fi
AC_ARG_ENABLE(samplemap, [ --disable-samplemap don't build the samplemap], samplemap=$enableval;samplemap_reason="configure parameter")
AM_CONDITIONAL(BUILD_SAMPLEMAP, [test "x$samplemap" = "xyes"])