summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwoglinde <woglinde@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-30 21:13:19 +0000
committerwoglinde <woglinde@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-30 21:13:19 +0000
commitd302ebe322f4a8bdffb30cf2bed30e32e45ff6d0 (patch)
tree6a3dc75d1d7c77f38521d7f6606793f724795bc4 /configure.in
parent8c3f8aceb8fa7b7b2f91ba3d5fc162da6089cb82 (diff)
downloadnavit-d302ebe322f4a8bdffb30cf2bed30e32e45ff6d0.tar.gz
Fix:core: define HAVE_SYS_TIME_H for autotools too
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4665 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bddb08964..b773e9bb8 100644
--- a/configure.in
+++ b/configure.in
@@ -345,6 +345,13 @@ AM_CONDITIONAL(EVENT_GLIB, [test "x$glib" = "xyes"])
AM_CONDITIONAL(SUPPORT_GLIB, [test "x$glib" = "xno"])
AM_CONDITIONAL(SUPPORT_EZXML, [test "x$glib" = "xno"])
+AC_CHECK_HEADER([sys/time.h],
+ [AC_DEFINE(
+ [HAVE_SYS_TIME_H],
+ [1],
+ [Define to 1 if you have the <sys/time.h> header file.])
+ ])
+
if test "x${ZLIB_CFLAGS}" = "x" -a "x${ZLIB_LIBS}" = "x"; then
AC_CHECK_HEADER(
zlib.h,