summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-06-16 21:39:56 +0000
committermdankov <mdankov@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-06-16 21:39:56 +0000
commite6ab92626129cd2cca4c830bffcba409beb2c0d4 (patch)
treef36d8c85ec6f8f8b862e95f484412b695360929a /configure.in
parentd319906654fca298ed0696e6a60b4a6322c55ade (diff)
downloadnavit-e6ab92626129cd2cca4c830bffcba409beb2c0d4.tar.gz
Fix:port_win32:Fix "Dollar S" bugs in navigational messages by adding own versions of *printf functions to support/glib. Fixes #1123, #1114. |Thank you ftom for initial version of the patch.
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5539 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2361c4139..d139d31e7 100644
--- a/configure.in
+++ b/configure.in
@@ -295,6 +295,10 @@ else
if test "x${win32}" != "xyes" -a "x${android}" != "xyes"; then
GLIB_LIBS="$GLIB_LIBS -lpthread"
fi
+ if test "x${win32}" == "xyes"; then
+ glib_use_own_printf=yes; glib_use_own_printf_reason="Win32/WinCE detected"
+ AC_DEFINE(GLIB_USE_OWN_PRINTF, 1, [Undef to make internal glib use system printf implementation.])
+ fi
fi
# gmodule
@@ -347,6 +351,7 @@ AC_SUBST(LIBNAVIT)
AM_CONDITIONAL(EVENT_GLIB, [test "x$glib" = "xyes"])
AM_CONDITIONAL(SUPPORT_GLIB, [test "x$glib" = "xno"])
+AM_CONDITIONAL(GLIB_USE_OWN_PRINTF, [test "x$glib_use_own_printf" = "xyes"])
AM_CONDITIONAL(SUPPORT_EZXML, [test "x$glib" = "xno"])
AC_CHECK_HEADER([sys/time.h],