summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorakashihi <akashihi@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-03-16 08:21:11 +0000
committerakashihi <akashihi@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-03-16 08:21:11 +0000
commitfcdec279d40e39d22f075abc851e2a5f851e6fc1 (patch)
tree683cf1878f581476ce2449b1fa87d05473c3e77b /configure.in
parenta3b920d6d355679a6f968448f8a9714fdcd4e572 (diff)
downloadnavit-fcdec279d40e39d22f075abc851e2a5f851e6fc1.tar.gz
Fix:core:Added Qt version check into gui_qml requirements checking
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@3018 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index fb249aa4d..f9beee87d 100644
--- a/configure.in
+++ b/configure.in
@@ -783,12 +783,12 @@ AM_CONDITIONAL(GUI_WIN32, test "x${gui_win32}" = "xyes")
# qml
AC_ARG_ENABLE(gui-qml, [ --disable-gui-qml disable gui type QML], gui_qml=$enableval;gui_qml_reason="configure parameter")
if test "x${gui_qml}" = "xyes" -a "x${QT_GUI_CFLAGS}" = "x" -a "x${QT_GUI_LIBS}" = "x"; then
- PKG_CHECK_MODULES(QT_GUI, [QtGui QtCore], ,gui_qml=no,gui_qml_reason="Packages QtGui and/or QtCore missing")
+ PKG_CHECK_MODULES(QT_GUI, [QtGui QtCore], ,gui_qml=no;gui_qml_reason="Packages QtGui and/or QtCore missing")
fi
if test "x${gui_qml}" = "xyes" -a "x${QT_DECLARATIVE_CFLAGS}" = "x" -a "x${QT_DECLARATIVE_LIBS}" = "x"; then
- PKG_CHECK_MODULES(QT_DECLARATIVE, [QtDeclarative], ,gui_qml=no,gui_qml_reason="Packages QtDeclarative missing")
+ PKG_CHECK_MODULES(QT_DECLARATIVE, [QtDeclarative >= 4.6.0 ], ,gui_qml=no;gui_qml_reason="Packages QtDeclarative missing")
fi
-if test "x${graphics_qt_qpainter}" = "xyes" ; then
+if test "x${gui_qml}" = "xyes" ; then
AC_DEFINE(USE_GUI_QML, 1, [Build with gui qml])
MOC=`$PKG_CONFIG QtGui --variable=moc_location`
if test "x${MOC}" = "x"; then
@@ -802,8 +802,6 @@ AC_SUBST(QT_DECLARATIVE_CFLAGS)
AC_SUBST(QT_DECLARATIVE_LIBS)
AM_CONDITIONAL(GUI_QML, test "x${gui_qml}" = "xyes")
-AM_CONDITIONAL(GUI_QML, test "x${gui_qml}" = "xyes")
-
## plugins
# pedestrian
AC_ARG_ENABLE(plugin-pedestrian, [ --enable-plugin-pedestrian enable pedestrian plugin], plugin_pedestrian=$enableval;plugin_pedestrian_reason="configure parameter")