summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2009-02-12 08:53:46 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2009-02-12 08:53:46 +0000
commit58273c8eaca58028f958ab40e81ff4a3bc927732 (patch)
treeb499ff245faf27ca7b4943ac1d5aecc524e6739b /configure.in
parente94f0d9e150b89aa53b0ca5ee58ceb56f76ab453 (diff)
downloadnavit-58273c8eaca58028f958ab40e81ff4a3bc927732.tar.gz
Add:Core:Added disable switch for glib
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@2040 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 55cf91f1a..99bc2c4f6 100644
--- a/configure.in
+++ b/configure.in
@@ -137,7 +137,11 @@ fi
X_CFLAGS="-I$x_includes"
AS_IF([test -n "$ac_x_libraries"], [X_LIBS="-L$ac_x_libraries"])
-PKG_CHECK_MODULES(GLIB, [glib-2.0 gthread-2.0], [glib=yes],[glib=no])
+# glib
+AC_ARG_ENABLE(glib, [ --disable-glib don't build with external glib], glib=$enableval, glib=yes)
+if test x"${glib}" = "xyes"; then
+ PKG_CHECK_MODULES(GLIB, [glib-2.0 gthread-2.0], [glib=yes],[glib=no])
+fi
if test "x${glib}" = "xyes"; then
AC_DEFINE(HAVE_GLIB, 1, [Define to 1 if you have (external) glib library])
else
@@ -146,7 +150,10 @@ else
fi
# gmodule
-PKG_CHECK_MODULES(GMODULE, [gmodule-2.0], [gmodule=yes], [gmodule=no])
+AC_ARG_ENABLE(gmodule, [ --disable-gmodule don't build with gmodule], gmodule=$enableval, gmodule=yes)
+if test x"${gmodule}" = "xyes"; then
+ PKG_CHECK_MODULES(GMODULE, [gmodule-2.0], [gmodule=yes], [gmodule=no])
+fi
if test "x${gmodule}" = "xyes"; then
AC_DEFINE(HAVE_GMODULE, 1, [Define to 1 if you have gmodule])
else