summaryrefslogtreecommitdiff
path: root/navit/xpm/Makefile.am
diff options
context:
space:
mode:
authorhorwitz <horwitz@ffa7fe5e-494d-0410-b361-a75ebd5db220>2009-03-30 14:12:30 +0000
committerhorwitz <horwitz@ffa7fe5e-494d-0410-b361-a75ebd5db220>2009-03-30 14:12:30 +0000
commit7cbc629b1fbfd9a96153e1fa353432a1e398c2ea (patch)
tree2bcb2173b616de92730d4d6cc486083ad11c1c14 /navit/xpm/Makefile.am
parent7597154c412335eec39210f004178cfc572833b1 (diff)
downloadnavit-7cbc629b1fbfd9a96153e1fa353432a1e398c2ea.tar.gz
Fix:Core:Properly handle distclean for generated PNGs|Thanks Pini for the patch
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@2175 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'navit/xpm/Makefile.am')
-rw-r--r--navit/xpm/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/navit/xpm/Makefile.am b/navit/xpm/Makefile.am
index c06e36af8..0c7274c96 100644
--- a/navit/xpm/Makefile.am
+++ b/navit/xpm/Makefile.am
@@ -183,20 +183,20 @@ endif
if USE_SVG2PNG
%.png:$(srcdir)/*.svg
SRCDIR=$(srcdir) $(srcdir)/navit_svg2png "@SVG2PNG@" "$@"
-xpm_DATA += $(addsuffix .png,$(basename $(svgs)))
+pngs = $(addsuffix .png,$(basename $(svgs)))
xsize=$(firstword $(subst x, ,$(scale)))
ysize=$(lastword $(subst x, ,$(scale)))
comma=,
if USE_SVG2PNG_SCALES
-xpm_DATA += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(svgs))))
+pngs += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(svgs))))
endif
if USE_SVG2PNG_SCALES_FLAG
-xpm_DATA += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES_FLAG@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(flag_svgs))))
+pngs += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES_FLAG@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(flag_svgs))))
endif
if USE_SVG2PNG_SCALES_NAV
-xpm_DATA += $(addsuffix .png,$(basename $(nav_svgs)))
-xpm_DATA += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES_NAV@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(nav_svgs))))
+pngs += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES_NAV@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(nav_svgs))))
endif
+xpm_DATA += $(pngs)
endif
DESKTOPFILEdir=$(datadir)/applications
@@ -211,3 +211,8 @@ ICON22_DATA = desktop_icons/22x22/navit.png
EXTRA_DIST = $(xpm_DATA) $(DESKTOPFILE_DATA) $(ICON128_DATA) $(ICON22_DATA) navit_svg2png
#burgerking.ico:
# wget http://www.burgerking.de/favicon.ico -O burgerking.ico
+
+if USE_SVG2PNG
+distclean-local:
+ rm -f $(pngs)
+endif