summaryrefslogtreecommitdiff
path: root/navit/map/shapefile/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'navit/map/shapefile/Makefile.am')
-rw-r--r--navit/map/shapefile/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/navit/map/shapefile/Makefile.am b/navit/map/shapefile/Makefile.am
index 35e420e84..ba6e22886 100644
--- a/navit/map/shapefile/Makefile.am
+++ b/navit/map/shapefile/Makefile.am
@@ -5,10 +5,11 @@ if PLUGINS
else
noinst_LTLIBRARIES = libmap_shapefile.la
endif
-if HAVE_SYSTEM_SHAPEFILELIB
libmap_shapefile_la_SOURCES = shapefile.c
-libmap_shapefile_la_LDFLAGS = -module -avoid-version @NAVIT_MODULE_LDFLAGS@ @SHAPEFILE_LIBS@
-else
-libmap_shapefile_la_SOURCES = shapefile.c dbfopen.c shpopen.c shptree.c shapefil.h
libmap_shapefile_la_LDFLAGS = -module -avoid-version @NAVIT_MODULE_LDFLAGS@
+if HAVE_SYSTEM_SHAPEFILELIB
+libmap_shapefile_la_LDFLAGS += @SHAPEFILE_LIBS@
+else
+AM_CPPFLAGS += -I$(top_srcdir)/navit/support/shapefile
+libmap_shapefile_la_LDFLAGS += $(top_srcdir)/navit/support/shapefile/libsupport_shapefile.la
endif