summaryrefslogtreecommitdiff
path: root/navit/vehicle/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'navit/vehicle/qt5/CMakeLists.txt')
-rw-r--r--navit/vehicle/qt5/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/navit/vehicle/qt5/CMakeLists.txt b/navit/vehicle/qt5/CMakeLists.txt
new file mode 100644
index 000000000..411d9d6ee
--- /dev/null
+++ b/navit/vehicle/qt5/CMakeLists.txt
@@ -0,0 +1,6 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+
+module_add_library(vehicle_qt5 vehicle_qt5.cpp)