summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Improved comment.curleyDistancePoiCharles Curley2018-08-271-1/+2
| | | | modified: navit/gui/gtk/gui_gtk_poi.c
* The distance to points of interest has been rendered in kilometersCharles Curley2018-08-271-184/+96
| | | | | | | | | | | even if the user has asked for imperial. This commit fixes that. We convert to feet only, and not miles, because the code sorts on the numeric value of the distance, so it doesn't like two different units. Currently, the distance is an int. Can it be made a float? Possible future enhancement? modified: navit/gui/gtk/gui_gtk_poi.c
* Replaced one of the two source strings for the PoI window prompt for ↵Charles Curley2018-08-271-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | inputting the search radius. Pull Request 557. modified: navit/gui/gtk/gui_gtk_poi.c modified: po/af.po.in modified: po/ar.po.in modified: po/ast.po.in modified: po/be.po.in modified: po/bg.po.in modified: po/bs.po.in modified: po/ca.po.in modified: po/ckb.po.in modified: po/cs.po.in modified: po/cy.po.in modified: po/da.po.in modified: po/de.po.in modified: po/de_CH.po.in modified: po/el.po.in modified: po/en.po.in modified: po/en_AU.po.in modified: po/en_CA.po.in modified: po/en_GB.po.in modified: po/eo.po.in modified: po/es.po.in modified: po/et.po.in modified: po/eu.po.in modified: po/fa.po.in modified: po/fi.po.in modified: po/fil.po.in modified: po/fo.po.in modified: po/fr.po.in modified: po/fr_CH.po.in modified: po/fy.po.in modified: po/gl.po.in modified: po/he.po.in modified: po/hi.po.in modified: po/hr.po.in modified: po/hu.po.in modified: po/id.po.in modified: po/it.po.in modified: po/ja.po.in modified: po/jv.po.in modified: po/kk.po.in modified: po/kn.po.in modified: po/ko.po.in modified: po/ku.po.in modified: po/lb.po.in modified: po/lt.po.in modified: po/lv.po.in modified: po/mk.po.in modified: po/ml.po.in modified: po/mn.po.in modified: po/mr.po.in modified: po/nb.po.in modified: po/nds.po.in modified: po/nl.po.in modified: po/nn.po.in modified: po/pl.po.in modified: po/pms.po.in modified: po/pt.po.in modified: po/pt_BR.po.in modified: po/ro.po.in modified: po/ru.po.in modified: po/sc.po.in modified: po/si.po.in modified: po/sk.po.in modified: po/sl.po.in modified: po/sq.po.in modified: po/sr.po.in modified: po/sv.po.in modified: po/sw.po.in modified: po/ta.po.in modified: po/te.po.in modified: po/th.po.in modified: po/tr.po.in modified: po/uk.po.in modified: po/ur.po.in modified: po/vi.po.in modified: po/zh_CN.po.in modified: po/zh_HK.po.in modified: po/zh_TW.po.in
* Made it prettier. Reformatted one commented and tabified the thing.Charles Curley2018-08-271-26/+22
| | | | modified: navit/gui/gtk/gui_gtk_poi.c
* 1) Changed the translation string for "Distance(m)" from "" to "Distance". ↵Charles Curley2018-08-271-0/+104
| | | | | | | | | | | | | | | | Rational: the "m" is ambiguous, it could be meters or miles. However, in the POI context, feet are more likely than miles. So take it out entirely. I did it this way rather than run sed on the entire collection of po input files. 2) The display code sorts the entries by distance. It has no way of knowing if "5" is five miles or five feet. So we leave the distances in feet or meters (depending on the setting for imperial). Allowing kilometers or miles might be a future enhancement. 3) See bug 556 (https://github.com/navit-gps/navit/issues/556). Rather than remove the spurious one as part of this fix, I will leave that to later. But both now have the same English "translation", "Select a search radius from screen center". This hides the problem, at least from English users. This affects all four en_*.po.in files. 4) Someone who knows more than I do about the translation strings might have a better idea. Particularly, is there a graceful way to indicate the input units, either miles or kilometers? modified: navit/gui/gtk/gui_gtk_poi.c modified: po/en.po.in modified: po/en_AU.po.in modified: po/en_CA.po.in modified: po/en_GB.po.in
* Refactor:gui/internal: Add pointer and label when using function "view on ↵lains2018-08-216-66/+277
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | map" (#631) * Factorizing gui_internal_cmd_results_to_map() to also highlight points selected by command "View on map" * Adding comments on displayed text for type_waypoint and type_route_end * Adding comments * Restoring zoom_to_rect in gui_internal_cmd_results_to_map() * Making zoom_to_rect conditional, moving results_map preparation code to a dedicated function * Moving "search_results" map preparation into a dedicated function * Removing unused var * Adding doxygen comments and disabling widget dealloc (causes segfault) * Fixing segfault at next do_drawy() when adding pointer for view on map * Reformatting labels to be displayed in a compact square area rather than all on a line * Applying astyle to comply to ci_sanity_checks.sh * Handling newlines in labels associated to element_circle * Fixing hardcoded nblines * Moving multi-line label processing to a dedicated function multiline_label_draw() * Rework on arg naming to line-up with other simular functions. Minor update on doxygen comments * Moving unsigned int sqrt calculation to utils * Minor improvement of comment * Fixing typo on comment * Also applying size xslt processing to layer itemgra This allows to also process the size of item_types="found_item", which is used by "View on map" and "Show results on map"
* cleanup:maptool: use g_strcmp0 instead of strcmp (#434)Joseph Herlant2018-08-2110-113/+113
|
* Revert Fix because the docker image was fixedjkoan2018-08-141-1/+0
|
* Fix Android apk VersionCode (#633)jkoan2018-08-122-2/+27
| | | | | | | | | | | | | | | | | | | | | | | | | | * Create git-scm-version.gradle * Update build.gradle * Update git-scm-version.gradle * Update build.gradle * Update git-scm-version.gradle * Update git-scm-version.gradle * Update git-scm-version.gradle * Update git-scm-version.gradle * Update git-scm-version.gradle * Update git-scm-version.gradle * Update git-scm-version.gradle * chnage to get release tags
* Fix latlon2bookmark (#627)jkoan2018-08-122-2/+2
| | | | | | * fix:latlon2bookmark:Fix to be able to compile latlon2bookmark * fix:latlon2bookmark:Add Wall
* Refactor:core:Minor documentation amendmentmvglasow2018-08-041-1/+1
| | | | Signed-off-by: mvglasow <michael -at- vonglasow.com>
* Fix build on circleci for androidjkoan2018-07-261-0/+1
|
* Fix:build:Disable map/garmin on Androidmvglasow2018-07-251-0/+1
| | | | Signed-off-by: mvglasow <michael -at- vonglasow.com>
* Fix:build:Disable vehicle/gpsd on Androidmvglasow2018-07-251-0/+1
| | | | Signed-off-by: mvglasow <michael -at- vonglasow.com>
* Add:build:Make gradlew executablemvglasow2018-07-201-0/+0
| | | | Signed-off-by: mvglasow <michael -at- vonglasow.com>
* Add:build:Ignore gradle artifactsmvglasow2018-07-201-0/+4
| | | | Signed-off-by: mvglasow <michael -at- vonglasow.com>
* update in-tree espeak to espeak-1.48.04 (#624)Stefan Wildemann2018-07-15309-7119/+15711
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * update in-tree espeak to espeak-1.48.04 Update the C-ified version of espeak to espeak-1.48.04. Currently builds and links for Sailfish. Untested for Windows builds yet. Throws a lot of warnings still. * Make private functions static in espeak. Convert the obviously private functions to static in order to fix warnings. There are a lot not so obvious left that are used in other files by extern statement. Silly. * correctly assign exported methods to headers This asigns exported functions to headers avoiding missing prototypes warning. * move vars out of for loop as Sailfish disallows c99 Standard build under Sailfosh disallows c99 features. Therefore move variables out of for loop declaration. * espeak prepare for Windows build * fix:speech:espeak Adapt to newer espeak version 1.48.04 * redo. removing the files from build was the false way * Disable mbrola support as this fails on windows * remove uneccesary posix calls on windows
* Refactoring:graphics Improving quality of circles on platforms without ↵lains2018-07-151-18/+33
| | | | | | | | | | native circle method (#628) * Improving quality of circles on platforms without native circle draw methods. Adding doxygen comments. * Updating verbiage * in circle_to_points(): renaming pnt to center and making in const
* Fix:scripts:WinCE build script (remove sample map, add espeak-data) (#632)lains2018-07-153-5/+19
| | | | | | | | | | | | * Fixing WinCE build script Remove inclusion of sample map in zip package (which, in addition, fails currently because map server is down) Allow running script twice by performing cleanup on directories if already created Adding missing espeak-data to zip package (currently missing and makes navit speech synthesis fail on current WinCE builds) * Adding xslt processor to build env * Pre-filling <vehicle> tag for WinCE
* Refactor:core:Improve documentation of route_value_seg()mvglasow2018-06-101-9/+16
| | | | Signed-off-by: mvglasow <michael -at- vonglasow.com>
* Merge pull request #625 from aerostitch/sanity_supportStefan Wildemann2018-06-051-30/+34
|\ | | | | update:scripts:change the sanity script to exclude fib and support
| * update:scripts:change the sanity script to exclude fib and supportJoseph Herlant2018-06-051-30/+34
|/
* cleanup:scripts:Use $(..) instead of legacy `..` to make codefactor happy (#623)Joseph Herlant2018-06-059-55/+55
|
* cleanup:python:cleanup python scripts (#622)Joseph Herlant2018-06-053-18/+18
|
* update:scripts:simplify the variables concatenation (#620)Joseph Herlant2018-06-052-2/+2
|
* cleanup:osd&support_espeak:get rid of unused-variables compilation warnings ↵Joseph Herlant2018-06-052-21/+20
| | | | | | | | (#619) * update:support_espeak:only declare the variable if used * cleanup:osd:remove unused variable
* Merge pull request #621 from navit-gps/revert_612_for_sailfishStefan Wildemann2018-06-051-2/+6
|\ | | | | Revert #612 for sailfish build script
| * move the file name to the right spotJoseph Herlant2018-06-041-2/+2
| |
| * Change parenthesis substitutuin as per CodeFactor requestStefan Wildemann2018-06-051-2/+2
| |
| * Revert #612 for sailfish build scriptStefan Wildemann2018-06-051-2/+6
|/ | | | | | | Whatever the 'enhancement' done in #612 should bring, it causes grep to complain for non existing file in Sailfish's MER SDK. Most probably because the escaping of the parenthesis was wrongly considered. Never mind - revert.
* update:scripts:change the scripts that use non-POSIX functionnalities to ↵Joseph Herlant2018-06-042-2/+2
| | | | bash v2 (#618)
* fix:scripts:replace \s with the supported use of the space class (#617)Joseph Herlant2018-06-041-1/+1
|
* cleanup:scripts:removes deprecated usage of egrep (#616)Joseph Herlant2018-06-041-1/+1
|
* fix:scripts:fix malformed shebang (#615)Joseph Herlant2018-06-041-1/+1
|
* update:scripts:avoid iterating over ls output by using glob (#614)Joseph Herlant2018-06-041-1/+1
|
* update:scripts:change the scripts that use non-POSIX functionnalities to ↵Joseph Herlant2018-06-044-4/+4
| | | | bash (#613)
* update:style:optimize the usage of cat in shell scripts (#612)Joseph Herlant2018-06-042-13/+8
|
* cleanup:win32:Remove unused variables (#611)Joseph Herlant2018-06-041-5/+0
|
* Fix:cmake:Fix the way we set the LIB_DIR when LIBDIR is set for backward ↵Joseph Herlant2018-06-031-4/+4
| | | | compatibility (#574)
* Fix:debug:Fix potential unterminated C--string and refactoring ↵lains2018-06-031-22/+113
| | | | | | | | | | | | | | | | | | debug_vprintf() (#564) * Fixing dbg() change introduced in 221f783ea1caaaab2f5ceadc6b0fb3e720aac3df * Fixing potentially missing terminating NUL char after EOL. Adding doxygen comment and refactoring debug_vprintf() to use only one fixed-size buffer. Adding asserts to protect from buffer overflows * Using memmove() rather than deprecated bcopy() * Using g_strlcpy() instead of strcpy() as indicated by aerostitch * Adding comments in the string-processing code for debug_vprintf() * Applying astyle to prepare merging with trunk after PR#569 * Fixing line length to respect style
* add:doc:add codefactor.io (#599)jkoan2018-06-031-0/+2
|
* change:ci:Move checkstyle.xml to be used by Codefactor.io (#608)jkoan2018-06-032-1/+1
| | | | | | | | * Rename navit/android/navit_checkstyle.xml to navit_checkstyle.xml * Rename navit_checkstyle.xml to checkstyle.xml * Update build.gradle
* update:ci:Refactor the sanity check for better output and add xmllint check ↵Joseph Herlant2018-06-031-19/+43
| | | | | | | | | | | | (#609) * update:ci:Refactor the sanity check for better output and add xmllint check * Use sort -u * Switch to git diff with trunk so that we avoid re-checking files coming from merge commits * Make sure to really take the extension properly in the comparison
* add:desktop:Add keywords to application desktop file (#610)Joseph Herlant2018-06-031-0/+1
|
* change:gui:Add underscore to internal gui keyboard. (#607)tengel2018-06-021-1/+1
|
* add:ci:Add sanity check script on circleci (#606)Joseph Herlant2018-05-303-7/+68
| | | | | | * add:ci:Add sanity check script * fix:ci:use setup_common_requirements.sh for installing pre-requisites
* Cleanup:global:force the re-attach the return type to the function ↵Joseph Herlant2018-05-30159-6541/+3470
| | | | | | | | declaration (#605) * Cleanup:global:force the re-attach the return type to the function declaration * cleanup:global:some loose ends
* Merge pull request #604 from aerostitch/reformat_javamvglasow2018-05-291-4/+2
|\ | | | | Cleanup:android: re-attach return type to function declaration
| * Cleanup:android: re-attach return type to function declarationJoseph Herlant2018-05-291-4/+2
|/
* cleanup:cmake:retab all CMakeLists.txt filesJoseph Herlant2018-05-2521-937/+937
|