summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2020-08-26 18:20:18 +0200
committerNiels Möller <nisse@lysator.liu.se>2020-08-26 18:20:18 +0200
commit456137ff89e0a1a5e5dd4e1ffa24bcd42a8a6fc2 (patch)
tree70725c31f8f34d80603edb16f6d5b30007921c82 /configure.ac
parent7d5351e18ca7fc86b62e85558e7b84c5e0850317 (diff)
downloadnettle-456137ff89e0a1a5e5dd4e1ffa24bcd42a8a6fc2.tar.gz
Add power FAT_TEST_LIST, and make --enable-power-crypto-ext default to false.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 212f8e78..fddde464 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,11 +89,9 @@ AC_ARG_ENABLE(x86-sha-ni,
AC_HELP_STRING([--enable-x86-sha-ni], [Enable x86_64 sha_ni instructions. (default=no)]),,
[enable_x86_sha_ni=no])
-# Default yes for initial testing
AC_ARG_ENABLE(power-crypto-ext,
- AC_HELP_STRING([--enable-power-crypto-ext], [Enable POWER crypto
-extensions. (default=yes)]),,
- [enable_power_crypto_ext=yes])
+ AC_HELP_STRING([--enable-power-crypto-ext], [Enable POWER crypto extensions. (default=no)]),,
+ [enable_power_crypto_ext=no])
AC_ARG_ENABLE(mini-gmp,
AC_HELP_STRING([--enable-mini-gmp], [Enable mini-gmp, used instead of libgmp.]),,
@@ -450,6 +448,8 @@ if test "x$enable_assembler" = xyes ; then
if test "x$enable_fat" = xyes ; then
asm_path="powerpc64/fat $asm_path"
OPT_NETTLE_SOURCES="fat-ppc.c $OPT_NETTLE_SOURCES"
+ FAT_TEST_LIST="none crypto_ext"
+ fi
elif test "x$enable_power_crypto_ext" = xyes ; then
asm_path="powerpc64/p8 $asm_path"
fi