summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2020-12-08 17:51:46 +0100
committerNiels Möller <nisse@lysator.liu.se>2021-01-05 14:12:34 +0100
commitebf9ae834d73b9374f6ea45f1e939921682747fe (patch)
treeb3a25284f1d3c8d59aaaf1f0b06b7c3a93a6562a /configure.ac
parent1c88685a3421753509772823c05f3355ff6486ee (diff)
downloadnettle-ebf9ae834d73b9374f6ea45f1e939921682747fe.tar.gz
Recognize arm64 in configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 763df3b5..e76f9375 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,18 @@ case "$host_cpu" in
ABI=64
])
;;
+ aarch64)
+ AC_TRY_COMPILE([
+#if defined(__aarch64__)
+#error 64-bit powerpc
+#endif
+ ], [], [
+ ABI=32
+ ], [
+ ABI=64
+ ])
+ ;;
+
esac
if test "x$ABI" != xstandard ; then
@@ -459,6 +471,17 @@ if test "x$enable_assembler" = xyes ; then
fi
fi
;;
+ aarch64*)
+ if test "$ABI" = 64 ; then
+ asm_path=arm64
+ else
+ # As far as I understand, Neon instructions are unlikely to be
+ # missing. It may be omitted "only for implementations
+ # targeting specialized markets", to quote the Armv8 reference
+ # manual.
+ asm_path="arm/neon arm/v6 arm"
+ fi
+ ;;
*powerpc64*)
if test "$ABI" = 64 ; then
GMP_ASM_POWERPC_R_REGISTERS