summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2018-12-26 11:30:21 +0100
committerNiels Möller <nisse@lysator.liu.se>2018-12-26 11:30:21 +0100
commitfc30c4d8276db2802d844be0c6c2cc67ff2d43cf (patch)
tree24ce9f3a3cb7225ec63d6631df8e432ced079cf7 /configure.ac
parent16d8133bec6d196ce3c5d02349a6475efaccf6c0 (diff)
parent350d87626235a20ec299ea851ef0b81218f1a5ec (diff)
downloadnettle-fc30c4d8276db2802d844be0c6c2cc67ff2d43cf.tar.gz
Merge branch 'release-3.4-fixes' into master
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a3460853..455463d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl -*- mode: shell-script; sh-indentation: 2; -*-
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([nettle], [3.4], [nettle-bugs@lists.lysator.liu.se])
+AC_INIT([nettle], [3.4.1], [nettle-bugs@lists.lysator.liu.se])
AC_PREREQ(2.61)
AC_CONFIG_SRCDIR([arcfour.c])
# Needed to stop autoconf from looking for files in parent directories.
@@ -11,10 +11,10 @@ AC_CONFIG_AUX_DIR([.])
AC_CONFIG_HEADER([config.h])
LIBNETTLE_MAJOR=6
-LIBNETTLE_MINOR=4
+LIBNETTLE_MINOR=5
LIBHOGWEED_MAJOR=4
-LIBHOGWEED_MINOR=4
+LIBHOGWEED_MINOR=5
dnl Note double square brackets, for extra m4 quoting.
MAJOR_VERSION=`echo $PACKAGE_VERSION | sed 's/^\([[^.]]*\)\..*/\1/'`
@@ -260,9 +260,9 @@ fi
# Checks for libraries
if test "x$enable_public_key" = "xyes" ; then
if test "x$enable_mini_gmp" = "xno" ; then
- AC_CHECK_LIB(gmp, __gmpz_powm_sec,,
+ AC_CHECK_LIB(gmp, __gmpn_sec_div_r,,
[AC_MSG_WARN(
- [GNU MP not found, or too old. GMP-5.0 or later is needed, see http://gmplib.org/.
+ [GNU MP not found, or too old. GMP-6.0 or later is needed, see https://gmplib.org/.
Support for public key algorithms will be unavailable.])]
enable_public_key=no)