summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2020-09-21 20:07:10 +0200
committerNiels Möller <nisse@lysator.liu.se>2020-09-21 20:07:10 +0200
commit2e6c93ca0f1d3814411b009c90abd2d70e71edea (patch)
treea05632cbc65d502233732a92f24d5215fdd84bc2 /configure.ac
parentdc89647b3033c943f3ac9a82e90dee6299ce0449 (diff)
downloadnettle-2e6c93ca0f1d3814411b009c90abd2d70e71edea.tar.gz
ppc: Add configure test and macros to replace register names.
* aclocal.m4 (GMP_ASM_POWERPC_R_REGISTERS): New configure test, adapted from corresponding test in GMP's acinlude.m4. * configure.ac (ASM_PPC_WANT_R_REGISTERS): New substituted variable. Set using GMP_ASM_POWERPC_R_REGISTERS, when powerpc64 assembly code is enabled. * config.m4.in: Substituted here. * powerpc64/machine.m4: Check ASM_PPC_WANT_R_REGISTERS, and if needed, replace register names like r0, r1, ... with integers. * Makefile.in (%.asm): Include m4-utils.m4 for preprocessing of .asm files, and include config.m4 before machine.m4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 666b2f4a..e9983697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,6 +399,7 @@ fi
OPT_NETTLE_SOURCES=""
FAT_TEST_LIST=""
+ASM_PPC_WANT_R_REGISTERS="n/a"
# Select assembler code
asm_path=
@@ -456,6 +457,7 @@ if test "x$enable_assembler" = xyes ; then
;;
*powerpc64*)
if test "$ABI" = 64 ; then
+ GMP_ASM_POWERPC_R_REGISTERS
asm_path="powerpc64"
if test "x$enable_fat" = xyes ; then
asm_path="powerpc64/fat $asm_path"
@@ -588,6 +590,7 @@ else
IF_ASM='#'
fi
AC_SUBST([IF_ASM])
+AC_SUBST([ASM_PPC_WANT_R_REGISTERS])
AH_VERBATIM([HAVE_NATIVE],
[/* Define to 1 each of the following for which a native (ie. CPU specific)