summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2020-07-31 19:54:07 +0200
committerNiels Möller <nisse@lysator.liu.se>2020-07-31 19:54:07 +0200
commit2fe775ee8428401d79fb9bff3cbc35cd91bfeee6 (patch)
tree3e98d8cb105c62d3eeb56c1f631a4c95f518aed7 /configure.ac
parentd1e45e07f51c1c1c73aca52ff1f3d4d6465c95b6 (diff)
downloadnettle-2fe775ee8428401d79fb9bff3cbc35cd91bfeee6.tar.gz
New make target check-fat
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6d5fdd8..d8b7b072 100644
--- a/configure.ac
+++ b/configure.ac
@@ -383,6 +383,7 @@ if test "x$ABI" != xstandard ; then
fi
OPT_NETTLE_SOURCES=""
+FAT_TEST_LIST=""
# Select assembler code
asm_path=
@@ -397,6 +398,9 @@ if test "x$enable_assembler" = xyes ; then
if test "x$enable_fat" = xyes ; then
asm_path="x86_64/fat $asm_path"
OPT_NETTLE_SOURCES="fat-x86_64.c $OPT_NETTLE_SOURCES"
+ # For now, not enabling aesni or sha_ni, since at least
+ # the latter appears unavailable on te gitlab test machines.
+ FAT_TEST_LIST="vendor:intel vendor:amd"
else
if test "x$enable_x86_aesni" = xyes ; then
asm_path="x86_64/aesni $asm_path"
@@ -421,6 +425,7 @@ if test "x$enable_assembler" = xyes ; then
if test "x$enable_fat" = xyes ; then
asm_path="arm/fat $asm_path"
OPT_NETTLE_SOURCES="fat-arm.c $OPT_NETTLE_SOURCES"
+ FAT_TEST_LIST="arch:5 arch:6,neon"
else
case "$host_cpu" in
armv6* | armv7*)
@@ -547,6 +552,7 @@ fi
AC_SUBST([OPT_NETTLE_OBJS])
AC_SUBST([OPT_HOGWEED_OBJS])
AC_SUBST([OPT_NETTLE_SOURCES])
+AC_SUBST([FAT_TEST_LIST])
AC_SUBST([ASM_RODATA])
if test "x$enable_assembler" = xyes ; then
IF_ASM=''