summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2013-12-17 22:10:10 +0100
committerNiels Möller <nisse@lysator.liu.se>2013-12-17 22:10:10 +0100
commit5c8127d4af4518ca12e14dbc0dd31c0d2fad9191 (patch)
tree2029c1a5548a19fd1141020d35ae167cc9d1c255 /configure.ac
parenta692074f478722cd50c0c90e60b6f470f66680b7 (diff)
downloadnettle-5c8127d4af4518ca12e14dbc0dd31c0d2fad9191.tar.gz
Attempt to get asm rodata working on macosx.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a4deaae5..acfc59cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -332,10 +332,19 @@ EOF
AC_MSG_WARN([No assembler files found.])
fi
fi
+ case "$host_os" in
+ darwin*)
+ ASM_RODATA='.section __TEXT,__const'
+ ;;
+ *)
+ ASM_RODATA='.section .rodata'
+ ;;
+ esac
fi
AC_SUBST([OPT_ASM_NETTLE_SOURCES])
AC_SUBST([OPT_ASM_HOGWEED_SOURCES])
+AC_SUBST([ASM_RODATA])
AH_VERBATIM([HAVE_NATIVE],
[/* Define to 1 each of the following for which a native (ie. CPU specific)