summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..af4730c
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,37 @@
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'Ninka',
+ VERSION_FROM => 'lib/Ninka.pm',
+ ABSTRACT_FROM => 'lib/Ninka.pm',
+ LICENSE => 'agpl_3',
+ AUTHOR => [
+ 'Daniel M. German <dmg@uvic.ca>',
+ 'Yuki Manabe <y-manabe@ist.osaka-u.ac.jp>',
+ 'René Scheibe <rene.scheibe@gmail.com>',
+ ],
+ EXE_FILES => ['bin/ninka'],
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => '6.52',
+ },
+ PREREQ_PM => {
+ 'File::Basename' => '0',
+ 'File::Spec::Functions' => '0',
+ 'Getopt::Std' => '0',
+ 'IPC::Open3' => '0',
+ },
+ TEST_REQUIRES => {
+ 'File::Temp' => '0',
+ 'Test::More' => '0.98',
+ 'Test::Strict' => '0',
+ },
+ META_MERGE => {
+ resources => {
+ homepage => 'http://ninka.turingmachine.org/',
+ repository => 'https://github.com/dmgerman/ninka',
+ license => 'http://www.gnu.org/licenses/agpl-3.0.html',
+ },
+ },
+);