summaryrefslogtreecommitdiff
path: root/deps/uv/CMakeLists.txt
diff options
context:
space:
mode:
authorcjihrig <cjihrig@gmail.com>2019-05-15 13:24:08 -0400
committerRuben Bridgewater <ruben@bridgewater.de>2019-05-22 10:18:21 +0200
commitaed74ccb4c1bbd0f121bc3bb31781c9d6adfcd36 (patch)
tree80f475004e07c24b7de11e6eac209e73b22591af /deps/uv/CMakeLists.txt
parent594c9868a3a98b2510514b748c5d885561ed32c5 (diff)
downloadnode-new-aed74ccb4c1bbd0f121bc3bb31781c9d6adfcd36.tar.gz
deps: upgrade to libuv 1.29.1
Notable changes: - uv_get_constrained_memory() has been added. - A race condition in uv_async_send() has been fixed. - uv_get_free_memory() and uv_get_total_memory() now read from /proc/meminfo, which should improve correctness when called from inside an lxc container. - A failed assertion in uv_fs_poll_stop() has been fixed. - A bug in MAC addresses for IP-aliases has been fixed. Fixes: https://github.com/nodejs/node/issues/27170 Fixes: https://github.com/nodejs/node/issues/27493 PR-URL: https://github.com/nodejs/node/pull/27718 Reviewed-By: Refael Ackermann <refack@gmail.com> Reviewed-By: Ali Ijaz Sheikh <ofrobots@google.com> Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl> Reviewed-By: Santiago Gimeno <santiago.gimeno@gmail.com> Reviewed-By: Rich Trott <rtrott@gmail.com> Reviewed-By: James M Snell <jasnell@gmail.com>
Diffstat (limited to 'deps/uv/CMakeLists.txt')
-rw-r--r--deps/uv/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/deps/uv/CMakeLists.txt b/deps/uv/CMakeLists.txt
index 7b25511939..b3890ddf57 100644
--- a/deps/uv/CMakeLists.txt
+++ b/deps/uv/CMakeLists.txt
@@ -297,8 +297,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
src/unix/linux-inotify.c
src/unix/linux-syscalls.c
src/unix/procfs-exepath.c
- src/unix/sysinfo-loadavg.c
- src/unix/sysinfo-memory.c)
+ src/unix/sysinfo-loadavg.c)
endif()
if(CMAKE_SYSTEM_NAME STREQUAL "NetBSD")