summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Early <alexander.early@gmail.com>2018-06-03 14:07:30 -0700
committerAlexander Early <alexander.early@gmail.com>2018-06-03 14:07:30 -0700
commit7f05f5c1d982d610f7535ed285e4c5ffa536f5d3 (patch)
tree177792e87cab1efdde3cefdc077f41afe4a4b9ee
parent3015ce6f1674f917e8eeec29c263686bfbcf7a6e (diff)
downloadasync-7f05f5c1d982d610f7535ed285e4c5ffa536f5d3.tar.gz
clean up debugging
-rw-r--r--.travis.yml4
-rw-r--r--Makefile6
2 files changed, 1 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index f00d7a9..1601f53 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -17,8 +17,6 @@ env:
after_success: npm run coveralls
-before_install:
- - sudo apt-get install -y make
# Needed to run Karma with Firefox on Travis
# http://karma-runner.github.io/0.13/plus/travis.html
@@ -29,8 +27,6 @@ before_script:
script:
- "[ $BROWSER == true ] || npm test"
# ensure buildable
- - "[ $MAKE_TEST == false ] || make --version"
- - "[ $MAKE_TEST == false ] || make list"
- "[ $MAKE_TEST == false ] || make -j 4"
# test in firefox
- "[ $BROWSER == false ] || npm run mocha-browser-test"
diff --git a/Makefile b/Makefile
index 860b4e8..e8ff7aa 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,7 @@
-# This makefile is meant to be run on OSX/Linux. Make sure any artifacts
+# This makefile is meant to be run on OSX/Linux. Make sure any dist/ artifacts
# created here are checked in so people on all platforms can run npm scripts.
# This build should be run once per release.
-OLD_VARS := $(.VARIABLES)
-
SHELL=/bin/bash
export PATH := ./node_modules/.bin/:$(PATH):./bin/
@@ -49,8 +47,6 @@ $(A): $$(SRC_$(A))
endef
$(foreach A,$(ALIAS_ES),$(eval $(COPY_ES_ALIAS)))
-$(foreach V,$(filter-out $(OLD_VARS), $(.VARIABLES)), $(info $(V): $($(V))))
-
all: clean lint build test
test: